[r211] Failed to open any project - DLL error

Bugs will be moved here once resolved.

Post » Tue Aug 11, 2015 7:36 am

Problem Description
After triyng to open any project or start new one I'm getting error message:
Image
It says that failed to initialize DLL (error 1114)

Description of Capx
Works on any CAPX and even new projects.

Steps to Reproduce Bug
  • Menu > new
  • select any option


Operating System and Service Pack
Windows 10

Construct 2 Version ID
Release 211 (64 bit)
B
55
S
14
G
10
Posts: 287
Reputation: 7,677

Post » Tue Aug 11, 2015 7:48 am

I've checked and this error occurs since r210.
B
55
S
14
G
10
Posts: 287
Reputation: 7,677

Post » Mon Aug 17, 2015 10:59 am

Does anybody have the same error?
B
55
S
14
G
10
Posts: 287
Reputation: 7,677

Post » Mon Aug 17, 2015 2:07 pm

Can't reproduce and nobody else is reporting the issue, so it must be a problem specific to your system. Sorry, not sure what we could do about this. Maybe check your graphics drivers are up to date? The "File - New" or "Open project" steps are the moment the editor first creates an OpenGL view, which is where most buggy graphics drivers then throw an error.
Scirra Founder
B
399
S
236
G
89
Posts: 24,543
Reputation: 195,430

Post » Mon Aug 24, 2015 2:56 pm

I have the same error.
just upgraded my old laptop to windows 10, installed construct 2 and got the same. (and my graphic driver are up to date)
B
2
Posts: 1
Reputation: 152

Post » Mon Aug 24, 2015 3:04 pm

@Moredeth

Moredeth wrote:I have the same error.
just upgraded my old laptop to windows 10, installed construct 2 and got the same. (and my graphic driver are up to date)


This is a closed bug report. If you think you have an actual bug then you should make a new post following all of the guidelines.

Regardless, I reckon your problem is with your system rather than C2. Drivers for Win 10 are hardly upto date, and the OS itself can hardly be called stable. I know of dozens of people who have uninstalled Win 10 already, but each to their own.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
136
S
31
G
87
Posts: 5,490
Reputation: 60,266

Post » Mon Aug 24, 2015 6:29 pm

That is weird, it did work for a week on win 10, until update r212, which now fails constantly.
B
3
Posts: 1
Reputation: 177

Post » Mon Aug 24, 2015 7:50 pm

Sorry to post on closed bug thread, but i actually managed to fix this on my Windows 10 64bit laptop computer.

If you have changeable graphics on your computer ( I have hd4000 and Radeon m7000hd series graphics cards), make sure it doesn't use the default hd4000 or what ever you may have. Force it to use (in my case) Radeon card.

If that doesn't help, heres something to try:
- Run Command Prompt as Administrator.
- Inside the command prompt window, type sfc /scannow then press the enter key.
- Wait for the process to complete to 100%

Again sorry for this post, but didn't want to make new thread, because it's really not C2 bug. And my system is fixed now.
B
3
S
1
Posts: 6
Reputation: 339

Post » Tue Aug 25, 2015 7:46 am

Jabadoo wrote:If you have changeable graphics on your computer ( I have hd4000 and Radeon m7000hd series graphics cards), make sure it doesn't use the default hd4000 or what ever you may have. Force it to use (in my case) Radeon card.

Thanks for advices. Where in Windows 10 do you change this?
B
55
S
14
G
10
Posts: 287
Reputation: 7,677

Post » Tue Aug 25, 2015 8:27 am

tecbug wrote:
Jabadoo wrote:If you have changeable graphics on your computer ( I have hd4000 and Radeon m7000hd series graphics cards), make sure it doesn't use the default hd4000 or what ever you may have. Force it to use (in my case) Radeon card.

Thanks for advices. Where in Windows 10 do you change this?


Right click anywhere on the desktop and select "changeable graphics", it was second from top.
There you can add construct2's EXE-file (mine is in "program files/scirra") to the list and set it to "high performance" or something similar, I have it in Finnish, so don't know exact term in English.

Hope this helps.
B
3
S
1
Posts: 6
Reputation: 339

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest