[r211] Font quality bug

Bugs will be moved here once resolved.

Post » Tue Aug 18, 2015 6:37 pm

Problem Description
Not a 100% sure this is a bug or just some settings issues, however as I haven't changed any I lean towards there being something wrong, but might be related to Chrome/NW.js The issue is with the quality of fonts.
In case this is related to Chrome, are there any way to fix it so it at least works for NW.js?

Image
The left side is from the C2 editor and the right when running in NW.js examine the quality there is a huge difference between it. Like all smoothing have been removed from runtime.

Attach a Capx
https://dl.dropboxusercontent.com/u/109921357/Font_bug/Font_bug.capx

Description of Capx
Nothing just 3 text objects.

Steps to Reproduce Bug
Start capx and observe

Observed Result
Text looses quality during runtime.

Expected Result
That the text looked as in the C2 editor

Affected Browsers
  • Chrome: (YES)
  • Internet Explorer: (NO)

Operating System and Service Pack
Windows 7

Construct 2 Version ID
r211
B
44
S
11
G
2
Posts: 1,182
Reputation: 6,848

Post » Tue Aug 18, 2015 10:21 pm

Seems that this is a problem in Chrome. For those having similar problem it can be solved by turning on "Clear type font" in the display properties.

But would be nice if C2 would be able to overwrite this settings if possible, if not then this should of course not be seen as a bug.
B
44
S
11
G
2
Posts: 1,182
Reputation: 6,848

Post » Thu Aug 20, 2015 11:36 am

Can't reproduce, appears fine in both NW.js and Chrome here.

Since you indicate that you had Cleartype disabled, I assume this problem is because you basically turned off high-quality text rendering system-wide, so closing.
Scirra Founder
B
402
S
238
G
89
Posts: 24,644
Reputation: 196,095


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests