[r211] Objects and layers tick boxes error.

Bugs will be moved here once resolved.

Post » Tue Aug 11, 2015 2:35 pm

Problem Description
On checking and unchecking the layers and objects buttons nothing happens I cannot see any objects and layers boxes on screen, very slight annoyance when trying to add layers.

Also receive an error message when clicking the construct logo in the top left......

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Retrieving configuration out of range

Condition: index < all_configs_cache.size()
File: Projects\ProjectConfigs.cpp
Line: 357
Function: class Configuration *__cdecl ProjectConfigs::GetConfigurationAt(unsigned __int64) const
Build: release 211 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort Retry Ignore
---------------------------

Attach a Capx
Not needed all projects suffer new/old.

Description of Capx
N/A

Steps to Reproduce Bug
  • attempt to view the objects box
  • attempt to view the layers box
  • press the construct 2 logo in the top left corner

Observed Result
Construct 2 crashes when pressing the top left construct 2 logo, unable to view object and layers boxes no matter how many times I tick un tick them in the view.

Expected Result
Not to crash when clicking the top left construct 2 button and be able to view the objects and layers boxes when ticking and unticking them in the view option.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
Windows 10

Construct 2 Version ID
r211
B
5
S
1
Posts: 12
Reputation: 363

Post » Tue Aug 11, 2015 2:46 pm

If you don't post a .capx can you at least give precise steps to make this error occur, please?

I am using r211 and I cannot make this error occur using what little instructions you have given, which leads me to believe it's likely a problem with your system, especially as no one else has reported such a problem.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
136
S
31
G
86
Posts: 5,488
Reputation: 59,762

Post » Tue Aug 11, 2015 3:30 pm

Test file...And some screens below...I will try a reinstall tonight as it might just be my setup, I have only had windows 10 for a few days so it could be that maybe, just thought this was worth mentioning.

https :// drive.google.com/file/d/0B5CXigd_CkZbVkZPMnZjeng2Rlk/view?usp=sharing

https :// drive.google.com/file/d/0B5CXigd_CkZbTGFhcmY5akxOODA/view?usp=sharing

https :// drive.google.com/file/d/0B5CXigd_CkZbbF9qRnUxRVBrSHM/view?usp=sharing

https :// drive.google.com/file/d/0B5CXigd_CkZba0dLbDJvS1gzbTg/view?usp=sharing

edit sorry not allowed to post a link so had to put spaces.

Basically I can't get objects and layer boxes to appear on the main screen by selecting them under the view check boxes, when I check them nothing happens either way, so if I tick to remove them nothing happens and when I check to show them nothing happens, I can however get this to work with other checkboxes such as "Bookmark" and other view options just layers and objects nothing seems to happen for me.


Regards

Sunny87
B
5
S
1
Posts: 12
Reputation: 363

Post » Mon Aug 17, 2015 1:10 pm

Can't reproduce in r211, besides, if clicking the top-left menu button crashes C2 then I'm sure we'd be hearing about it from loads of users, but so far it's only you. I think that suggests an issue specific to your system rather than with C2.

The .capx you shared is completely empty so there's nothing to see changing when toggling layers. I tested it with the Space Blaster demo project and it was working fine.
Scirra Founder
B
399
S
236
G
89
Posts: 24,527
Reputation: 195,386


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests