r216 - NW.JS Export error

Bugs will be moved here once resolved.

Post » Mon Nov 23, 2015 1:31 pm

instead of creating an own topic I'll add my experience with this bug here:

Problem Description
While exporting a Project with the NW.js export option I get the following error Message:
"error during export cannot open file info.plist":
Image

The same problem appeared on 2 different PCs, both Windows 7 64bit- one Professional, 1 Ultimate Win7 Version

Attach a Capx
https://www.dropbox.com/s/r6t9444o5i6u3 ... .capx?dl=0

Description of Capx
new project Capx - no content, other than an empty white sheet (see above screenshot)

Steps to Reproduce Bug
  • Open Construct2
  • Create new Project
  • Export via NW.js

Observed Result
Image

after navigating to the folder and starting the exporter .exe file
Image

Expected Result
fully functional files for MacOS, Win32, Win64 & Linux

Affected Browsers
  • .exe: YES
  • Chrome: NO
  • FireFox: NO
  • Internet Explorer: NO

Operating System and Service Pack
Windows 7 Professional SP1
Windows 7 Ultimate SP1

Construct 2 Version ID
r216
B
8
S
1
G
1
Posts: 29
Reputation: 735

Post » Mon Nov 30, 2015 8:06 am

Hello,

I am having the same problem. Do you manage to solve it?

Thanks.
B
5
S
1
Posts: 9
Reputation: 395

Post » Mon Nov 30, 2015 11:42 am

Which version of NW do you use?
Image Image
B
19
S
10
G
125
Posts: 867
Reputation: 64,937

Post » Mon Dec 07, 2015 9:36 am

I'm also having the same problem. R216 64-bit from Steam, using the NW.js downloaded from the Scirra site, version 0.13.0 alpha 6.
B
5
S
1
Posts: 6
Reputation: 403

Post » Mon Dec 07, 2015 2:42 pm

This can be closed, you guys did not read that the new NW.js versions require Construct 2 r217 or newer!!!
Look it up again and please, just read for at least 2 seconds and you will find it! ;) (CLICK HERE)

If you want to keep using the latest stable release of C2 and NW.js features, simply download NW.js version v0.12.0.
ImageImageImageImage
B
51
S
18
G
75
Posts: 625
Reputation: 42,491

Post » Tue Dec 08, 2015 6:01 am

TheRealDannyyy wrote:This can be closed, you guys did not read that the new NW.js versions require Construct 2 r217 or newer!!!


I see now. However, that could be a bit more up front, the only place it says this is in the "Older Version Downloads" section.
B
5
S
1
Posts: 6
Reputation: 403

Post » Wed Dec 16, 2015 4:46 pm

Closing, please make sure you use r217+ for the latest NW.js versions.
Scirra Founder
B
383
S
225
G
86
Posts: 24,119
Reputation: 190,546

Post » Mon Dec 21, 2015 2:40 am

When is the steam version getting updated?
B
5
S
1
Posts: 9
Reputation: 395

Post » Mon Dec 21, 2015 7:36 am

hola mi problema es que cuando quiero usar el construct 2 me sale que dejo de funcionar y busque para solucionar el problema y me dice que es incompatible yo tengo windows 7 le agradecería si me pueden ayudar desde ya muchas gracias
B
3
Posts: 1
Reputation: 177


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests