[r218 UPDATED!] NW.js (α7) Plugin Is Not Working Correctly

Bugs will be moved here once resolved.

Post » Fri Nov 20, 2015 8:02 am

Problem Description
The plugin is almost back to its normal state, most of the errors are fixed.

Short Reminder: This report was made to keep track of the features that are currently not working with the latest version of NW.js .

Code: Select all
OLD/v2: Some actions and expressions of the NW.js plugin still return a javascript error.
(Tested: Set width/height, Request Attention, Set Window Title and many more available in the Capx below.)

Code: Select all
OLD/v1: The NW.js Plugin ACEs are not working at all, the exporting to NW.js seems to work but
the games (Win32&64 tested) just show a blank black screen and do nothing else.

Attach a Capx
Example Capx File: Download HERE!

Description of Capx
Includes some basic actions & expressions using the NW.js Plugin and default Buttons.

Steps to Reproduce Bug
  • Download the Capx
  • Open the Capx with latest C2 & NW.js installed
  • Test using preview or export (I prepared some stuff to test several basic functions.)

Observed Result
The Plugin is obviously broken at some parts and returns error messages.

Expected Result
I expect it to work like it did before r217.

Affected Browsers
  • NW.js "Native Like" Desktop: (YES)
  • Chrome: (NO)
  • FireFox: (NO)
  • Internet Explorer: (NO)

Operating System and Service Pack
Windows 7 with latest updates and up to date drivers.

Construct 2 Version ID
Newest beta release r218 Steam release. (With the latest alpha version of NW.js installed!) [Personal Edition]

Additional maybe usefull information:
  • 100% deleted and reinstalled NW.JS (v0.13.0 alpha 7)
  • Checked C2 data with the Steam software data check system (0 Errors Found)
Last edited by TheRealDannyyy on Tue Jan 12, 2016 9:37 pm, edited 6 times in total.
ImageImageImageImage
B
46
S
15
G
69
Posts: 571
Reputation: 38,935

Post » Wed Nov 25, 2015 11:03 pm

@TheRealDannyyy: I was wondering why I got a black screen with the new NW.js.
I thought I was missing something. Then I saw your post. I can confirm this.
B
46
S
12
Posts: 110
Reputation: 3,747

Post » Thu Nov 26, 2015 4:13 pm

byondisoft wrote:@TheRealDannyyy: I was wondering why I got a black screen with the new NW.js.
I thought I was missing something. Then I saw your post. I can confirm this.

I can confirm that on my end the exporting is fine now on Win 32 & 64 bit but the NW.js plugin is currently just a mess and seems to work only if it wants to.
ImageImageImageImage
B
46
S
15
G
69
Posts: 571
Reputation: 38,935

Post » Wed Dec 02, 2015 12:02 am

Can confirm same bug.
Windows 10, newest C2 Beta 218, as well as newest NWJS. 64 bit.
Export project -> Black screen, no run.
B
13
S
1
Posts: 52
Reputation: 738

Post » Thu Dec 10, 2015 1:31 am

I also get the following error when previewing with NW JS:

Javascript Error!
Uncaught ReferenceException:
in .. /html/ajax_plugin.js : process is not defined.
Line 55.

... help?

--- UPDATE ---
As a temporary fix, I reverted to 0.12.0 NW.JS from February. Works fine.
B
13
S
1
Posts: 52
Reputation: 738

Post » Thu Dec 10, 2015 3:15 pm

Ricethin wrote:I also get the following error when previewing with NW JS:

Javascript Error!
Uncaught ReferenceException:
in .. /html/ajax_plugin.js : process is not defined.
Line 55.

... help?

--- UPDATE ---
As a temporary fix, I reverted to 0.12.0 NW.JS from February. Works fine.

@Ricethin you might want to test out the latest version of NW.js (alpha7), maybe it is fixed now.
ImageImageImageImage
B
46
S
15
G
69
Posts: 571
Reputation: 38,935

Post » Thu Dec 10, 2015 7:07 pm

Ricethin wrote:I also get the following error when previewing with NW JS:

Javascript Error!
Uncaught ReferenceException:
in .. /html/ajax_plugin.js : process is not defined.
Line 55.

... help?

--- UPDATE ---
As a temporary fix, I reverted to 0.12.0 NW.JS from February. Works fine.


I have the same issue, it's been posted in the bugs forum by multple users. Thanks for the tip abpout reverting, wiill have to try that as a temp solution so I can keep working on things.
B
55
S
17
G
5
Posts: 184
Reputation: 8,871

Post » Wed Dec 16, 2015 5:41 pm

Most of these should be working in alpha 7, except 'request attention' which brings up an error. I've fixed that for the next beta. After the next beta/alpha 8+, please file separate bugs for each feature that is not working correctly.
Scirra Founder
B
373
S
218
G
83
Posts: 23,433
Reputation: 185,806

Post » Tue Jan 12, 2016 7:49 pm

Thanks!

I'm still using a slightly older version of NW JS that seems to have been working.
I have a huge project I'm working on, so I'm anxious to do any updating just yet, ha!
B
13
S
1
Posts: 52
Reputation: 738


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest