[R56] Save project - Check failure

Bugs will be moved here once resolved.

Post » Sun Sep 18, 2011 6:11 pm

1) Create a project
2) Create a sprite
3) Save the project
4) Now clone the sprite with "Ctrl + left mouse click" and the same time, save the project with "Ctrl + S".

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Project still marked as changed after save

Condition: !project->IsChanged()
File: Construct2.cpp
Line: 1502
Function: bool __thiscall CConstruct2App::SaveProject(class Project *)
Build: release 56 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abbrechen   Wiederholen   Ignorieren   
---------------------------

Then the following message appears

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Object texture leak: a texture is still loaded when cleaning up an ObjectTexture, check all textures released properly

Condition: gl_instances.empty()
File: Projects\ObjectTexture.cpp
Line: 39
Function: __thiscall ObjectTexture::~ObjectTexture(void)
Build: release 56 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 6)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abbrechen   Wiederholen   Ignorieren   
---------------------------
Counterfeit2011-09-18 18:12:11
B
23
S
4
G
7
Posts: 98
Reputation: 5,220

Post » Sun Sep 18, 2011 6:50 pm

[QUOTE=Counterfeit] 1) Create a project
2) Create a sprite
3) Save the project
4) Now clone the sprite with "Ctrl + left mouse click" and the same time, save the project with "Ctrl + S".
[/QUOTE]
I can't reproduce any issue. I hold control, start dragging, hit S (control is still down so it does Save), and it works OK. Am I missing something?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sun Sep 18, 2011 6:57 pm

Oh, just got the issue, seems to be a bit random. Hopefully fixed in the next build...
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests