[r59] capx crash and can't open

Bugs will be moved here once resolved.

Post » Thu Sep 29, 2011 3:13 am

I added Physic Behavior to the sprites series called "Alien_XXX",
then put some events to create hinges for them.
After running the layout to test, the total file crashed,
can't open it again.

Crashed Capx Download:
http://dl.dropbox.com/u/31590694/%5BBUG%5D%7BPhysics%7DAngrySalaryman_003.rar

Just a bug report,
don't waste time for fixing my capx, I'm familiar with remaking them anytime.
gonzdevour2011-09-29 03:13:58
B
110
S
28
G
8
Posts: 210
Reputation: 12,727

Post » Thu Sep 29, 2011 4:49 am

Here is your fixed capx:
http://dl.dropbox.com/u/5426011/fixed/AngrySalaryman_003fixed.capx
The Images for AlienActor, Alien_RightHand, Alien_Rightfoot, Alien_LeftFoot, Alien_Body, Alien_Head, Alien_Gun and Alien_LeftHand were all missing and need to be re-imported.

This bug sounds just like the bug here, which should be fixed in r60.

If it's different here is the check failure:
[code]
---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Cannot find project file for animation frame

Condition: FileExists(GetProjectPath().c_str())
File: Projects\AnimationFrame.cpp
Line: 186
Function: void __thiscall AnimationFrame::Load(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
Build: release 59 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 3)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------
[/code]R0J0hound2011-09-29 04:50:30
B
84
S
27
G
70
Posts: 4,933
Reputation: 49,558

Post » Thu Sep 29, 2011 5:02 am

Thank you , you're so kind!
B
110
S
28
G
8
Posts: 210
Reputation: 12,727

Post » Thu Sep 29, 2011 5:31 am

isn't he...
B
68
S
23
G
20
Posts: 1,053
Reputation: 30,823

Post » Thu Sep 29, 2011 1:29 pm

I had the same issue with images. Reverted back to r58. Now 12 hours later we have r60.

Sucks that I'm at work and can't tinker with it...
B
22
S
9
G
3
Posts: 203
Reputation: 3,647


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests