[r61] Search bug

Bugs will be moved here once resolved.

Post » Wed Oct 12, 2011 6:12 am

I found a bug with the search function. If you search for something on one event sheet, then go to another event sheet and clear the search, you'll only be able to see the results of the search when you go back to that original event sheet. Since you already cleared the search, there's nothing you can do to get it back except close and reopen the entire project(reopening the event sheet itself doesn't work).

This is extremely easy to replicate, but here's a cap anyway with two sheets with one nonsense event each:

http://dl.dropbox.com/u/19702035/bugtest.capx

Hopefully it's not just my computer.
B
20
S
9
G
6
Posts: 607
Reputation: 6,112

Post » Wed Oct 12, 2011 7:17 am

Confirmed.
Rejoice, it's not just your computer.

Apparently though, putting the focus back to the search field (when in the "hiding" event sheet) and pressing enter seems to display all events again. (I tried with a 2 nonsense events sheet)
Could you confirm @SullyTheStrange ?
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,999
Reputation: 57,793

Post » Wed Oct 12, 2011 7:19 am

Yes indeed, that does seem to fix the problem. I certainly didn't think to do so, though.

Good work.SullyTheStrange2011-10-12 07:19:42
B
20
S
9
G
6
Posts: 607
Reputation: 6,112

Post » Wed Oct 12, 2011 12:36 pm

You can also hit escape to clear the search. However, I'll see if I can make this clearer.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest