[r66] Check failure when changing global var

Bugs will be moved here once resolved.

Post » Mon Nov 07, 2011 8:15 pm

May be something happened when packaging it up for release?
B
72
S
25
G
9
Posts: 382
Reputation: 10,649

Post » Mon Nov 07, 2011 9:05 pm

Not if the second one didn't work either!
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Mon Nov 07, 2011 9:13 pm

yea im getting the same thing here
---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Returning NULL event variable

Condition: event_var != NULL
File: Projects\Parameters.cpp
Line: 285
Function: class EventVariable *__thiscall EventParameter::GetEventVariable(void) const
Build: release 66 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------



also getting a hard crash with no info when i change an instance var
3DGS2011-11-07 21:22:43
B
15
S
1
G
2
Posts: 62
Reputation: 1,696

Post » Mon Nov 07, 2011 9:19 pm

From other threads it seems some sort of bug when changing variables. May be something broke when adding descriptions to the variables?Nickydude2011-11-07 21:26:55
B
72
S
25
G
9
Posts: 382
Reputation: 10,649

Post » Mon Nov 07, 2011 10:15 pm

same thing happened to me, tried to use the system.compare variable on a global variable and got an error message
B
12
S
2
G
5
Posts: 23
Reputation: 3,320

Post » Mon Nov 07, 2011 11:18 pm

OK, I'm having to take shots in the dark here because it works for me. But I made some more changes - can you try this and see if it works any better?
http://www.scirra.com/downloads/releases/construct2-r66-quickfix2.exe
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Mon Nov 07, 2011 11:21 pm

Same problem, still cannot do anything with the instance and global variables. same errors even with the fix.

I'm on windows vista 32bit if that would make any difference what so ever.3DGS2011-11-07 23:43:25
B
15
S
1
G
2
Posts: 62
Reputation: 1,696

Post » Mon Nov 07, 2011 11:30 pm

Also crashes with the new fix. :(

Win 7 Home edition
32 bitNickydude2011-11-07 23:44:39
B
72
S
25
G
9
Posts: 382
Reputation: 10,649

Post » Mon Nov 07, 2011 11:36 pm

Samething here.. Poor Ashley

Windows 7 32 Bit
B
40
S
14
G
11
Posts: 243
Reputation: 9,432

Post » Mon Nov 07, 2011 11:57 pm

I tried on my XP virtual machine (32-bit, SP3) and it worked fine there too.

Is it working OK for anyone? I guess only people with issues come and post, maybe it's only affecting a small number of people? (I guess it's pretty obvious so you'd come to the forum right away if you had it)

Not sure where to go from here - I really need a repro my end to fix it.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

PreviousNext

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests