R70 Pin behaviour

Bugs will be moved here once resolved.

Post » Thu Dec 01, 2011 9:36 am

Has anyone noticed that the pin behaviour is no longer working in R70?
I don't think it's me, as the demo supplied with Construct2 also doesn't work??
B
12
S
2
G
1
Posts: 74
Reputation: 1,402

Post » Thu Dec 01, 2011 9:42 am

Hi.

I've just tested the example and it works OK for me. I even added the mouse object and 'unpinned' the shields when clicked, and it worked OK.

Are you getting an error message?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,844
Reputation: 48,289

Post » Wed Dec 07, 2011 3:15 pm

Hi zenox98,

Thanks for that, but for some reason the behaviour still doesn't work on my machine? There are no javascript errors being reported.

I have uploaded the original C2 demo file for someone to try.

Any help would be appreciated.

http://dl.dropbox.com/u/52484520/Pin%20behavior.capx
B
12
S
2
G
1
Posts: 74
Reputation: 1,402

Post » Wed Dec 07, 2011 5:15 pm

Works on mine too!
B
26
S
6
G
7
Posts: 67
Reputation: 5,079

Post » Wed Dec 07, 2011 5:24 pm

@planetserve, your example works just fine here. Maybe try reinstalling Construct 2?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,590

Post » Wed Dec 07, 2011 11:26 pm

I have reinstalled C2 several times, but to no avail.

I am running Vista (sadly) and cannot check on an XP machine, buy there is definitely a compatibility problem........although nothing is being reported via the error console..........
B
12
S
2
G
1
Posts: 74
Reputation: 1,402

Post » Wed Dec 07, 2011 11:32 pm

P.S. The original file (pin behaviour) also doesn't work on a friends vista machine. Bearing in mind that I have bought an early adopters license but my friend has not????
B
12
S
2
G
1
Posts: 74
Reputation: 1,402

Post » Thu Dec 08, 2011 12:41 pm

I've tried it on Vista and Win7 and it worked on both systems.
ImageImage
B
25
S
6
G
8
Posts: 773
Reputation: 6,643

Post » Thu Dec 08, 2011 1:25 pm

Very strange. On both machines, the shields are pinned to the cog, but they do not rotate?
B
12
S
2
G
1
Posts: 74
Reputation: 1,402

Post » Thu Dec 08, 2011 1:35 pm

What browser are you using, version, and your friend's ?
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests