[R72] no preview in IE,

Bugs will be moved here once resolved.

Post » Mon Dec 19, 2011 2:18 am

[R72] No preview or gray preview in IE. Works fine in Firefox/Chrome/ Opera.
Exporting and uploading project to a server works as expected in IE.

1.Open construct 2
2.New project single file.
3.Switch Preview browser to Internet Explorer
4.Run layout.

Internet explorer opens. Then one of two things happen. Either the error page "Internet Explorer cannot display the webpage" Or preview page loads with Gray screen . Copy/paste the preview URL into Chrome Firefox or opera results in normal working preview.

IE console reports no errors. But strangely If I clear the cache in the developers tools. Then refresh the preview page it loads just fine until IE closes.

Feels like It's my IE, but I'm not sure so I'm posting a report.
All my IE setting are Default as I only use it to test. this is true for both systems.    

Tested on two systems.
Windows 7 64bit
gtx560ti.

Windows 7 32bit
gt460

Thanks.
B
84
S
12
G
9
Posts: 99
Reputation: 9,508

Post » Mon Dec 19, 2011 3:50 pm

same here win 7 64bit IE9
I used to use r66 and last night i've updated to r72 and cannot preview in IE. Hiting F5 to refresh not helpig at all but it works when i press F12 and then while developers tools are running i refresh it - no need to clear the cache.
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Mon Dec 19, 2011 4:14 pm

Confirmed IE has been broken for two or three releases. Sometimes it doesn't load at all or if loads renders incorrectly like distorted view etc.
B
58
S
13
G
10
Posts: 632
Reputation: 12,505

Post » Mon Dec 19, 2011 5:07 pm

This appears to be an IE bug. Press F12 then F5 and it works fine. I've reported it to MS but they are being totally useless about fixing it, and of course the slow release cycle means it could be months before the fix is distributed anyway. So the best solution is to just use Chrome for preview, which is faster and has better features for HTML5 games.

This doesn't seem to affect exported projects, so your games should still work fine for IE9 users.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,468

Post » Sun Jan 08, 2012 2:26 pm

Actually this happens to me with an exported, uploaded game. Nothing shows no matter how much refresh. If I press F12 and reload, it works.

I do admit to having modified the index.html to display some extra stuff, but this shouldn't matter. It happened on several occasions as well, before my modifying that file.

Any workarounds, anybody?

Thanks.

B
14
S
5
G
7
Posts: 235
Reputation: 5,175

Post » Sun Jan 08, 2012 2:42 pm

OK guys I got it to work just now and as a bonus I do have a hint for Scirra devs and web devs in general.

Looks like if you try to write something to the debug console but the developer tools isn't running in I.E., then bad stuff happens.

In my case, I had a facebook object in the project, unused and not initialized. This was causing some warning to be written in the console. I removed the useless object, no more warning, I.E. properly loads.

As another hint, some time ago I encountered a very similar bug (on a business project, not involving games), which was very difficult to figure out. Seemed like it would "randomly" work on some computers and not on others (mostly not working on customers' computers, working on devs' computers - with exceptions). It was on Firefox then. Turned out, if you had Firebug installed it would work, otherwise not. We removed the Console warnings, or added some check for the console object being present (can't remember which of the two) and it started working for everybody.

Hope this will help someone in future, or perhaps even help fixing this bug.

Cheers.
B
14
S
5
G
7
Posts: 235
Reputation: 5,175

Post » Mon Jan 09, 2012 11:16 am

Thanks for the info @Geo, I disabled console logging in IE completely for the next build, let's see if that fixes it.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,468


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests