[R77] Fullscreen scaling not working properly

Bugs will be moved here once resolved.

Post » Sat Jan 28, 2012 5:46 am

Maybe I still don't understand how fullscreen scaling is supposed to work, but to me this looks broken.

Here's a platformer test with a window size of 240x252. Run in preview mode and you should see a familiar pink buggy rolling over a green mountainscape
http://dl.dropbox.com/u/57216006/fullScreenScale.capx

Now set Project->Fullscreen in Browser to On(scaled) and preview the project-> the background has disappeared.
B
12
S
3
G
3
Posts: 73
Reputation: 2,647

Post » Sat Jan 28, 2012 5:09 pm

Your layer middleground has its parallax option set to 50,100.
If you set it to 100,100 it's back on screen.

Guess you should look that way.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Sat Jan 28, 2012 10:34 pm

Well it's supposed to have a parallax effect and looks alright in windowed mode, but not in fullscreen-scaled.
B
12
S
3
G
3
Posts: 73
Reputation: 2,647

Post » Mon Jan 30, 2012 9:47 pm

Hi Ashley, have you had a chance to try this ?
B
12
S
3
G
3
Posts: 73
Reputation: 2,647

Post » Mon Jan 30, 2012 10:45 pm

It appears to be working correctly. When you zoom the scroll position changes on parallaxed layers which causes the offset.

Collisions between objects on parallaxed layers don't work correctly yet either, which is probably also confusing you. Try adding more objects to the foreground and middleground so it's clearer where you are and you should be able to see what is happening.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Mon Feb 06, 2012 6:48 am

Hey @Ashley,

I'm having some problems wrapping my head around parallax / fullscreen too. It doesn't work the way I expect it to and I think it's buggy.

Here's what I mean: CAPX.

It contains 2 layers, one of which has parallax 0,0.

Repro:

Switch the project property "Fullscreen in browser" between "Off" and "Scale mode", and run the project.

When "Off" it looks as I expect it to. Buttons on the zero-parallax layer show in the four corners.

When "Scale mode", it looks very weird.

Can you explain how this works, why is it like this?

What I'm trying to achieve is a "fixed" (HUD / GUI) layer staying in place, and a moving layer moving around. I need this to work on "Scale mode" fullscreen.

Thanks in advance.
B
14
S
5
G
7
Posts: 235
Reputation: 5,175

Post » Mon Feb 06, 2012 7:18 am

@Geo: You need to use the anchor behavior as explained in the tutorial about supporting multiple screen sizes.

Fixed capx
The only "buggy" thing is the text, being a single word (no spaces), it doesn't wrap but apparently displays only a single line, apparently modifying the size of the text object automaticly.
This is something I've noticed too recently (possibly since webfonts).
Kyatric2012-02-06 09:37:28
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Mon Feb 06, 2012 9:35 am

Thanks @Kyatric, the Anchor behavior indeed did the trick and I got the game to work EXACTLY how I want it to. I did read the tutorial, but somehow overlooked the Anchor stuff.

It seems weird (and counter-intuitive) to me that things should work like this (i.e. that I need to anchor stuff around to prevent it from scaling even though I set parallax to zero), but as long as I can get it to work the way I want it's all good.

Cheers!
B
14
S
5
G
7
Posts: 235
Reputation: 5,175

Post » Mon Feb 06, 2012 3:58 pm

You need to set the scale rate to 0 to prevent scaling, not the parallax. The parallax only affects scrolling, not size.

Maybe my transforms are the wrong way round after all - I'll see if I can adjust this to make it more intuitive.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests