R79.2 Family instance variable check failure

Bugs will be moved here once resolved.

Post » Tue Feb 14, 2012 6:23 pm

Specs:
Windows 7
Acer Aspire One
Construct 2 32-bit r79.2


Steps to reproduce:
1. Create project
2. Create a sprite1 and drop into layout
3. Create a family and add sprite1
4. Add an instance variable to family called var1
5. Attempt to drag another instance of sprite1 onto layout
6. Check failure results


Pasted text:
---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

No instance value for instance variable

Condition: i != instance_values.end()
File: Projects\InstanceVariable.cpp
Line: 176
Function: class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > __thiscall InstanceVariable::GetInstanceValueStr(class ObjectInstance *) const
Build: release 79.2 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------

B
30
S
6
G
8
Posts: 232
Reputation: 6,119

Post » Tue Feb 14, 2012 6:24 pm

Same bug? Thought Ashley fixed that in R79.
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Tue Feb 14, 2012 6:32 pm

Here's a quick capx if you want to see it. Try to drag an instance of sprite onto the layout.
Family variable instance check failure
B
30
S
6
G
8
Posts: 232
Reputation: 6,119

Post » Tue Feb 14, 2012 7:27 pm

Ah, a different case of the same bug :-\ I think I've fixed it now, looks like we'll have an r79.3 tomorrow...
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests