r80 Array & Local Variable Crash

Bugs will be moved here once resolved.

Post » Tue Feb 28, 2012 7:30 pm

Construct crash when having event "On start of layout" and add sub event "For each XY in array", the program crash/freeze (some times crash, some times freeze)

BUT this only happens in some event sheets... here is from the windows "stopped working"


Problem signature:
Problem Event Name:     APPCRASH
Application Name:     Construct2.exe
Application Version:     2.0.0.0
Application Timestamp:     4f4bc455
Fault Module Name:     USP10.dll
Fault Module Version:     1.626.7601.17514
Fault Module Timestamp:     4ce7c9f5
Exception Code:     c0000005
Exception Offset:     0000000000050716
OS Version:     6.1.7601.2.1.0.256.48
Locale ID:     1053
Additional Information 1:     f09a
Additional Information 2:     f09a4a939c3d7c48dd6279df35923dc5
Additional Information 3:     07a7
Additional Information 4:     07a7e791446a62a0417377d0dc4e4972


*Update*
I can create the event "on start of layout" and "for each xy element" separately and then drag the "for each xy element" into a sub event of "on start of layout" without a crash...

*Update 2*
When trying to add an local variables, I get following error:


---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Getting event sequence number from event without one assigned

Condition: sequence_number != 0
File: Projects\Event.cpp
Line: 30
Function: unsigned int __cdecl Event::GetEventSequenceNumber(void) const
Build: release 80 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------
zapmore2012-02-28 19:49:45
B
13
S
2
G
3
Posts: 43
Reputation: 3,041

Post » Tue Feb 28, 2012 7:49 pm

Possibly related to this bug.Kyatric2012-02-28 19:50:12
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791

Post » Tue Feb 28, 2012 7:54 pm

Yea looks like that, didn't suspect that it was a problem with the sub event, thought it was only with arrays and local variables. Sorry for double post then!
B
13
S
2
G
3
Posts: 43
Reputation: 3,041

Post » Wed Feb 29, 2012 3:33 pm

Can you check this is fixed in r80.2?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528

Post » Wed Feb 29, 2012 4:31 pm

Ashley, you have done it! Seems to be working fine again with adding local variables and sub events, great job!
B
13
S
2
G
3
Posts: 43
Reputation: 3,041


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests