r80 Crash when import more sprite frames

Bugs will be moved here once resolved.

Post » Wed Feb 29, 2012 10:09 am

WinXP SP3:
Import first frame of sprite. Set pivot point well out of sprite-box.(needed for rotary compo)
Rename sprite.
Position sprite's pivot point on the center of circular-level.
Import other 20 frames of that sprites animation.
Crash To Desktop.
Rolling back to 79.4 in order to finish entry.
B
25
S
5
G
5
Posts: 138
Reputation: 5,638

Post » Wed Feb 29, 2012 12:13 pm

I tried this and couldn't reproduce any issue. Can you describe in more detail the exact sequence of steps, especially when you are opening and closing the animations editor and how you import the image both for the first frame and rest of the frames?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,590

Post » Wed Feb 29, 2012 8:47 pm

Win XP SP3 32-bit, NVIDIA GTX280, 4GBRAM. I'm using a digipen (right hand) :)) Wacom Intuos 3 even for work with Construct 2, because its much more precise than the mouse. + mouse in left hand :)) so there are both type of input at once. :))

In 3DSMax i have rendered the sprite anim:
29 PNG files, 64x32x32bit

010000.png    size: 1828 bytes
...
010040.png    

Opened my CapX project in R80. (chose from "Recent" menu)
Zoomed out with CTRL+Mouse (i have to do precise pivot placements)
Double clicked on canvas
Insert new object
Sprite
One click on canvas
Edit Image OPEN
Browse to first frame PNG, bring it in,
Right click on Animation frames,
import frames
CTRL+A in file-browser window to select all anim frames,
deselect first frame
OK
All anim frames are imported
Click on Image Points, set image point outside sprite box area
close Edit Image
------------ At this point the first R80 version CTD-ed.
Precisely set pivot and rotate sprite to match position of rotating level..
this i could only do flawlessly with R79.4
B
25
S
5
G
5
Posts: 138
Reputation: 5,638

Post » Wed Feb 29, 2012 9:50 pm

Have you tried r80.2? There was a crash when closing the picture editor that was fixed, might be related. I just tried those exact steps in r80.2 and it worked fine.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,590

Post » Thu Mar 01, 2012 9:40 am

Just checked now. Working fine. Continue finishing my entry in r80.2.

Thank You!
B
25
S
5
G
5
Posts: 138
Reputation: 5,638


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests