r88 Sound not working

Bugs will be moved here once resolved.

Post » Fri May 04, 2012 9:12 am

Hiii,

The sound is not working on ie9 and phoneGap.
Is it a bug?

Also i tried to return my project from r87 to r84 where the sound was working there. so i open my project using TextPad editor to change the version from r87 to r84 and then open it on r84 version, but i got an error related to condition ID. Is there a way to solve this issue?

Thanxxx
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Fri May 04, 2012 8:11 pm

I just tried and sound works fine for me in IE9. Can you post a .capx reproducing the issue?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri May 04, 2012 8:41 pm

@Ashley I'm using IE9 version: 9.0.8112.16421 and here is a testing capx file.

http://dl.dropbox.com/u/52040403/sound%20r88.capx

Thanx :)
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Fri May 04, 2012 9:10 pm

You need to import a .m4a file for IE9 audio to work. You only have the .ogg file which IE9 does not support. If you're not getting sound on iOS, it would be for the same reason.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri May 04, 2012 9:12 pm

@Ashley Thanx i will try it, but how about android?mina2012-05-04 21:13:10
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Fri May 04, 2012 9:15 pm

and the sound was working before as ogg on ie9 and android, so is it changed recently?mina2012-05-04 21:16:57
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Fri May 04, 2012 9:54 pm

@mina it's impossible it was working in IE9 with ogg, IE9 has never supported ogg! You must have been confused somehow, I suppose you were testing with a .m4a file present?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sat May 05, 2012 8:15 am

@Ashley nothing changed
http://dl.dropbox.com/u/52040403/sound%20r88.capx
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Sat May 05, 2012 8:56 am

It doesn't have the same name, it's called music2. The m4a needs exactly the same name, so it's got to be "music.m4a".
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sat May 05, 2012 9:03 am

Thank u Ashley, I really appreciate ur help. It works fine now

One last question, as u told me it will works fine on ios now. am i right? and how about android?
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests