[ r93] Construct 2 Beta Release r93 crash

Bugs will be moved here once resolved.

Post » Tue Jun 12, 2012 7:56 pm

Hi Guys,

I have XP Pro SP3 32 Bit latest updates, NVidia GeForce 9500 GT with latest driver ( 301.42 ).

I am getting a Construct 2 Beta Release r93 crash right from the get go. I launch the program, click create a new project. Select store project in single file, click create project, I get:

Construct 2 game creator has encountered a problem and needs to close. We are sorry for the inconvenience.

AppName: construct2.exe      AppVer: 2.0.0.0      ModName: construct2.exe
ModVer: 2.0.0.0      Offset: 00052d51

Aidanaidanodr2012-06-12 20:06:54
B
5
Posts: 6
Reputation: 824

Post » Tue Jun 12, 2012 8:05 pm

I have reinstalled Construct 2 Release 90 - works fine,

Aidan
B
5
Posts: 6
Reputation: 824

Post » Tue Jun 12, 2012 8:27 pm

R94 has released about an hour ago.
Try downloading it and installing it, making sure all your drivers are up to date, and have a go at it ?
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Tue Jun 12, 2012 8:36 pm

This is always a graphics driver problem - please try updating them and also read this.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,610

Post » Tue Jun 12, 2012 10:07 pm

Hi Guys,

I already ( as mentioned in OP ) had updated to latest nVidia Driver.

I have just tried the R94 version - still same thing.

However - very curious ..

If I open the program, Create a new project from the panel when first opened, then store project in single file, click create project - I get the error in the OP, then have to close.

BUT If I reopen the program - File, Close Tab to get rid of the initial panel then go File, New, store project in single file - it opens up fine.

Now it would seem to be related to the initial "What do you want to do panel" that is the problem?

Aidan
B
5
Posts: 6
Reputation: 824

Post » Tue Jun 12, 2012 10:32 pm

Another small thing:

When you save as single file the save box pops up. Add name of file, press save - This save box stays on screen. You have to click elsewhere on screen to get rid of it.
B
5
Posts: 6
Reputation: 824

Post » Wed Jun 13, 2012 1:24 pm

I'm not sure what to do, since nobody else has encountered this issue, or other users with similar issues solved the problem by updating their drivers.

It may be that there is a bug in the latest driver. You might want to complain to nVidia and ask why they can't make a driver that works with modern software.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,610

Post » Wed Jun 13, 2012 10:48 pm

Is it an nVidia bug? Sounds odd in that their is a way to open a new file via File Menu / New. The problem is when one tries to open a new file from that initial panel that pops up when Construct 2 opens.

Im just wondering why video drivers would cause this?

Can you try on an XP Computer??

I also have a Win 7 Dell laptop with nVidia Card - I will try on that later.
B
5
Posts: 6
Reputation: 824

Post » Thu Jun 14, 2012 12:36 am

OK,

Tried it on this Dell Vostro 1720 with NVidia GeForce 9600m 64bit Win 7. All is fine on this machine.

I imagine this issue is something to do with XP??
B
5
Posts: 6
Reputation: 824

Post » Thu Jun 14, 2012 2:06 pm

@aidanodr - we have many XP users who are using C2 with no issues like you describe. The moment you press "Create project" or open a file is the first time Construct 2 creates the graphics-card rendered layout view, so if there is a driver problem this is the moment it will crash. I would advise contacting nVidia.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,610

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests