[r95] ajax plugin ios 5.1.1 safari - blank screen

Bugs will be moved here once resolved.

Post » Mon Jun 18, 2012 12:36 pm

hi,
this is the first time i post a problem here

when i create a project just showing a graphic it loads fine on all browsers including safari on an ipad 5.1.1

when i embed the ajax plugin (without coding anything with it)
it works fine with all browsers
but on safari on the ipad the project won't even load or display anything

can you help me?

thank you
ony
B
3
Posts: 4
Reputation: 283

Post » Mon Jun 18, 2012 12:46 pm

hi,
i was able to replicate the same problem on safari on my win7 machine
i get this error:

http://localhost:50000
Assertion failure: A plugin is missing. Check the plugin IDs match in edittime and runtime scripts. Note this can also occur when there is an error in a plugin script that prevents the browser from loading the script - check the error console.

Stack trace:
undefined
B
3
Posts: 4
Reputation: 283

Post » Mon Jun 18, 2012 1:33 pm

more news on this topic
the problem appears with all versions after r92
before that it works fine

please fix that
thank you
tony
B
3
Posts: 4
Reputation: 283

Post » Mon Jun 18, 2012 6:45 pm

Oops, turns out Safari on iOS doesn't support a function the AJAX plugin uses. Thanks, fixed for next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,574

Post » Mon Jun 18, 2012 7:42 pm

very cool & very quick response time
thank you !!!
B
3
Posts: 4
Reputation: 283

Post » Wed Jul 18, 2012 7:10 pm

I'm having issues in iOS Safari (and iOS Chrome) regarding the blank screen.
I'm getting javascript errors and they started appearing after I made a few changes to the game (one of them, adding AJAX element).

I'm running the last Construct version r95. Did you fix it?

Thanks
B
3
Posts: 3
Reputation: 331

Post » Wed Jul 18, 2012 8:10 pm

@diegog: According to the date of the posts, the "next build" at this period was r96.

Now, the most recent beta release is the r99, perhaps you should test this release and see if your project works better.Kyatric2012-07-18 20:10:48
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,999
Reputation: 57,793

Post » Wed Jul 18, 2012 8:22 pm

Good to know, thanks!

I'll give it a try
B
3
Posts: 3
Reputation: 331


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests