[R95] Spritesheet not saving very small animations

Bugs will be moved here once resolved.

Post » Fri Jun 15, 2012 3:10 pm

Windows 7 x64 Home Premium
Construct 2 R95

Construct will not save spritesheet at all in my particular case: sprite istelf is 1x1 px, and there's 2 frames. So if there's no at least 10 animation frames (when 2nd list is created), the whole animation is not saved on export. If there is only one sprite object in the scene, the "images" folder won't even be created.

About the example provided: 2 sprites, the left one (black pixel in project) has 9 animation frames so it's not saved. The right one (yellow) has 10 frames and so 2nd animation list is created (that's the bug border, i think).

CAPX
EXPORTED

Partial Workaround: As far as you're using sprite for storing just images (not for animated sequence) you can duplicate frames - the total length should be not less than 10 frames (from frame 0 to frame 9).
And there's no workaround for storing animation sequence... wait, you can jump over those frames via events NugMan2012-06-15 15:28:22
B
19
S
6
G
4
Posts: 171
Reputation: 2,507

Post » Fri Jun 15, 2012 4:29 pm

Oops. I'll try to get it fixed for the next build, but it's a shame you just missed the last stable release...
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,228

Post » Fri Jun 15, 2012 7:31 pm

One can't see to everything. Maybe R96 stable?
B
19
S
6
G
4
Posts: 171
Reputation: 2,507


Return to Closed bugs

Who is online

Users browsing this forum: byondisoft and 1 guest