[r99] open animation editor crashes

Bugs will be moved here once resolved.

Post » Fri Jul 13, 2012 7:54 am

When I open a the animation editor on a non empty sprite Construct crashes every time in [r99].

Windows 7 (64)
8GB RAM
AMD Phenom II x4 965
Nvida GeForce GTX 560 Ti
B
18
S
3
G
3
Posts: 29
Reputation: 2,724

Post » Fri Jul 13, 2012 12:59 pm

I get the same issue.

The issue only appears when left mouse clicking on the "edit" link in the animation properties. Right click on the image and choose "edit animation" works fine.

Steps to reconstruct issue:
1. Open a new Construct 2 project
2. Add a new object (image) to the project
3. Highlight added object (image)
4. Left mouse click on the "edit" by the "Animations" properties on the left side under the properties of the object (image).

You should now see that the edit image window opens, and directly get a windows crash message.

Computer specs:
winXP Professional Version 2002, SP3
Intel Core 2 QUAD CPU 2.4Ghz
3.0 GB RAM
Graphic: GeForce 8600 GTS
driver version: 301.42

Download capx example:
http://dl.dropbox.com/u/52716812/Scirra%20bugs/Edit_Animation_issue.capx
B
38
S
13
G
9
Posts: 151
Reputation: 8,427

Post » Fri Jul 13, 2012 5:07 pm

You are right.
Right click on the image and choose "edit animation" works fine. Also doubleclick seems to work.Fabian Schempp2012-07-13 17:07:54
B
18
S
3
G
3
Posts: 29
Reputation: 2,724

Post » Mon Jul 16, 2012 3:32 pm

Thanks, should be fixed in the next build. Meanwhile just double click the sprite as a workaround, that works fine.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests