[R99]Copy+Paste bug

Bugs will be moved here once resolved.

Post » Wed Aug 08, 2012 2:12 pm

Steps:
1 - Copyed an sprite with animations from one project.
2 - Pasted inside another project.
3 - This message appears:

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Calling AddBehaviorInstanceFor() when instance already has behavior instance

Condition: instances.find(&inst) == instances.end()
File: Projects\BehaviorType.cpp
Line: 170
Function: class BehaviorInstance *__cdecl BehaviorType::AddBehaviorInstanceFor(class ObjectInstance &)
Build: release 99 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Paste failed due to xml_exception during paste

Condition: false
File: Editors\CLayoutView.cpp
Line: 2777
Function: void __cdecl CLayoutView::DoPasteAt(class CPoint)
Build: release 99 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------


I cant reproduce it with other sprite objects. The funny thing is that Ive copyed and pasted another animation with the same number of frames and the same structure without problems.
sheepy2012-08-08 14:28:19
B
38
S
8
G
3
Posts: 438
Reputation: 6,869

Post » Wed Aug 08, 2012 2:27 pm

[QUOTE=sheepy] Steps:
1 - Copyed an sprite with animations from one project.
2 - Pasted inside another project.
3 - This message appears:

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Calling AddBehaviorInstanceFor() when instance already has behavior instance

Condition: instances.find(&inst) == instances.end()
File: Projects\BehaviorType.cpp
Line: 170
Function: class BehaviorInstance *__cdecl BehaviorType::AddBehaviorInstanceFor(class ObjectInstance &)
Build: release 99 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Paste failed due to xml_exception during paste

Condition: false
File: Editors\CLayoutView.cpp
Line: 2777
Function: void __cdecl CLayoutView::DoPasteAt(class CPoint)
Build: release 99 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------


I cant reproduce it with other sprite objects. The funny thing is that Ive copyed and pasted another animation with the same number of frames and the same structure without problems.
[/QUOTE]
B
38
S
8
G
3
Posts: 438
Reputation: 6,869

Post » Fri Aug 17, 2012 6:35 pm

Can't reproduce: I can copy and paste the player from Space Blaster (which has animations and behaviors) and paste it in to a new project and it works just fine. Can you share your specific .capx and instructions on which object to copy and where?
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,564

Post » Fri Aug 17, 2012 7:40 pm

Ive deleted everything, except the sprite and the error is still ocurring, hope this helps:
Note that even with the error message, the sprite is copied to the projects tab and can be used normally.
https://dl.dropbox.com/u/6813637/copy_sprite_from_here.capx
https://dl.dropbox.com/u/6813637/paste_here.capx
B
38
S
8
G
3
Posts: 438
Reputation: 6,869

Post » Mon Aug 20, 2012 2:30 pm

I'm missing the 'MoveTo' and 'EaseTween' behaviors. Can you reproduce the problem without having to use any third party addons?
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,564

Post » Mon Aug 20, 2012 3:34 pm

Ive deleted all the instances of MoveTo and EaseTween from the project Ive sent you, is there any other way to remove those from the project?
B
38
S
8
G
3
Posts: 438
Reputation: 6,869

Post » Mon Aug 20, 2012 4:41 pm

The behaviors are still in 'paste_here.capx'. Make sure all objects using them have the behaviors removed, then save-as to a new .capx to ensure they are removed, and share that .capx.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,564

Post » Mon Aug 20, 2012 4:56 pm

Okdoc, Ill do that later today ;]
B
38
S
8
G
3
Posts: 438
Reputation: 6,869

Post » Thu Aug 30, 2012 2:42 pm

Any update?
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,564

Post » Thu Aug 30, 2012 4:16 pm

Hey, Ive removed the behaviors from the paste_here file and now the copy and paste is working without errors ;]
https://dl.dropbox.com/u/6813637/paste_2.capx
B
38
S
8
G
3
Posts: 438
Reputation: 6,869

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests