Random freezes on Windows Phone 8 Device

Discussion and feedback on Construct 2

Post » Thu Feb 28, 2013 1:06 pm

Hi,

I'm working on a Windows Phone 8 version of my Game R.U.Nuts and I would like to know if someone already had a random freeze issue.

In fact, the game is well running but every one or two seconds the screen freezes during one second then keep on running.

Video Example : https://dl.dropbox.com/u/107104215/Movie.wmv

I encounter this on my HTC 8S but not on the Visual Studio 512M WVGA Emulator. Any clue?

Thanksbeufreecasse2013-02-28 15:13:25
B
14
S
4
G
2
Posts: 190
Reputation: 3,938

Post » Thu Feb 28, 2013 1:39 pm

Something very weird is that the freezing effect doesn't append if I continuously tap the screen ...
B
14
S
4
G
2
Posts: 190
Reputation: 3,938

Post » Thu May 09, 2013 12:07 pm

Hi @beufreecasse,

I've been testing a simple project on Window Phone too, and I'm getting a similar problem. Did you ever find a solution for R.U.Nuts?

After reading this thread, I tried tapping the screen constantly (as you mentioned), and if I do this, the game stops freezing up, weird!

Thanks, for any advice you might have.

PS Nice game, love the graphics!Blacksmith2013-05-09 12:19:17
B
32
S
6
G
7
Posts: 489
Reputation: 8,217

Post » Thu May 09, 2013 12:22 pm

@beufreecasse Can you try disabling all audio and see if that fixes it?
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

Post » Thu May 09, 2013 12:35 pm

Hi @thehen,

Not sure about @beufreecasse, but I'm currently using one of C2's built-in "starter" projects, just as a test for Windows Phone. I've used it straight out of the box, and haven't added any sound to the project!

B
32
S
6
G
7
Posts: 489
Reputation: 8,217

Post » Thu May 09, 2013 12:47 pm

@Blacksmith ah this is disconcerting. We've done a lot of work on the Windows Phone version of our game but don't have a HTC 8S to test on :X
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

Post » Thu May 09, 2013 12:48 pm

@beufreecasse,

Even stranger, just re-read your posts, and I'm also running the HTC 8S. So perhaps its hardware related, although I thought it was a decent mid range device when I bought it!

B
32
S
6
G
7
Posts: 489
Reputation: 8,217

Post » Thu May 09, 2013 1:04 pm

@thehen, yes it is quite worrying! I've been scratching my head for a while, trying to work out why I wasn't getting smooth performance on my device. Although still don't know for sure the device is the issue!

Anyway, I'd be happy to test for you if you need me to, and if you have any concerns I'm happy to sign an NDA, just let me know!

B
32
S
6
G
7
Posts: 489
Reputation: 8,217

Post » Thu May 09, 2013 2:30 pm

Hi,

I removed all the references to audio plugin to use windows phone audio plugin instead, I changed the whole project size too ( now all the project is sized to fit a 800x480 resolution)
I also updated my windows phone version and I don't have the issue anymore, but on Htc 8s performances are very poor.
I hope it will help.
B
14
S
4
G
2
Posts: 190
Reputation: 3,938

Post » Thu May 09, 2013 3:13 pm

@beufreecasse, thanks very much for the advice! I've update the phone and the game is running smoothly now (Wooo Hooo!)

@thehen, hopefully this is good news for you as well! With any luck, once you're ready to release Mortar Melon, most people should have made the update :)
B
32
S
6
G
7
Posts: 489
Reputation: 8,217

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 17 guests