Random objects going invisible

Get help using Construct 2

Post » Sun Sep 08, 2013 5:05 am

I'm not sure if this is a bug, and if it is I cannot, for the life of me, figure out how to reproduce it.

Randomly when I'm playing my game, "something" will happen that sets off a sequence of strange random events. Most notably random sprites will set themselves invisible (some of these objects don't even have a single line of code to them). Sometimes items that should be destroyed at the end of the animation aren't.

I know it sounds like a code issue, but I've checked all the areas that effect visibility and object destruction and nothing seems to tie together. Whenever this happens, it's never the same objects every time, either.

I know this information isn't helpful at all, but has anyone experienced any weird issues lately? I want to say it's since r143 but I can't be sure.
B
38
S
12
G
1
Posts: 527
Reputation: 4,087

Post » Sun Sep 08, 2013 9:35 am

Do you have a capx, or an exported version of your game so we can see this issue in real time?

If you just want to know if others have had this Issue: I haven't.

I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Sun Sep 08, 2013 10:05 am

I haven't
HARMLESS SIGNATURE THAT IS VIEWED BY OTHERS AS OFFENSIVE AND CONTROVERSIAL
B
14
S
3
G
3
Posts: 356
Reputation: 4,377

Post » Sun Sep 08, 2013 10:10 am

Oh no! What happened to my robot?
HARMLESS SIGNATURE THAT IS VIEWED BY OTHERS AS OFFENSIVE AND CONTROVERSIAL
B
14
S
3
G
3
Posts: 356
Reputation: 4,377

Post » Sun Sep 08, 2013 10:38 am

Do they set themselves invisible,or maybe move outside of the view, scale to nonexistant or have empty animation frame?
B
24
S
9
G
7
Posts: 756
Reputation: 7,292

Post » Sun Sep 08, 2013 1:27 pm

Or maybe the last animation frame has the origin point offset by a lot, causing that frame to by offscreen...
B
226
S
60
G
33
Posts: 902
Reputation: 39,989

Post » Sun Sep 08, 2013 5:11 pm

@LittleStain - The capx is too large, but I will be releasing a demo hopefully within a few days here.

@Vee1 - They set themselves invisible. I know this because a couple of the objects are enemies that shoot other objects based on image points, and the enemies are still shooting objects at the correct location while being invisible (and also take damage).

@Paradox - Also, if this were the case, it would be happening everytime.

Thanks for the responses guys - I'm incredibly confused. Half the time I test my game everything is fine and dandy.
B
38
S
12
G
1
Posts: 527
Reputation: 4,087

Post » Sun Sep 08, 2013 5:41 pm

I know this sounds weird... but sometimes I move the lines within the block of code and then move them back, then save. When the system saves it seems to "rewrite" the messed up coding to the correct code shown again. (although the code appeared correct in the first place but it didn't act like it was written)

I've had to do this in various areas before. Also, if something "breaks" unexpectedly and there is no apparent reason why I open the backup (you can set the system to do one daily) and I paste whatever code I've added since to that copy and it will work just fine. I know it sounds weird!
Eliyahna2013-09-08 17:42:19
B
18
S
2
Posts: 61
Reputation: 902

Post » Sun Sep 08, 2013 5:46 pm

@Eliyahna - would you see the rewritten code, though? As in something I can find if I were to sift through my code again? I'll have to check, but that still doesn't explain things disappearing that don't even have codes to them.
B
38
S
12
G
1
Posts: 527
Reputation: 4,087

Post » Sun Sep 08, 2013 5:49 pm

No the code looks fine to begin with, it just doesn't work. There will be nothing wrong with the way it's written. So I change it then change it back (in order for the system to allow a save for that area of coding) then save and it looks the same still... but it works now.

It's almost as if, even though it was written correctly, it just never saved in correctly or became corrupted.Eliyahna2013-09-08 17:50:39
B
18
S
2
Posts: 61
Reputation: 902

Next

Return to How do I....?

Who is online

Users browsing this forum: David181, vaticant and 4 guests