Replace Color Effect does not display in Chrome/NWjs Preview

Bugs will be moved here once resolved.

Post » Fri Mar 31, 2017 5:22 am

Problem Description
When in preview mode, whether testing in NWjs or Chrome, built in "Replace Color" effect does not display. When exported to NWjs or HTML5 or previewed in Microsoft Edge and Internet Explorer, "Replace Color" effect functions as expected.

Attach a Capx
https://1drv.ms/u/s!Atvbm976TQtmgr4fJYYWiWPvONxasQ

Description of Capx
Displays sprite with Scirra's "Replace Color" effect applied. Source color is dark grey outline, replacement color is a light blue. Button toggles effect off and on.

Steps to Reproduce Bug
  • Apply "Replace Color" effect to any sprite
  • Preview in Chrome or NWjs
  • Export to NWjs or HTML5

Observed Result
Effect does not display in preview mode for Chrome or NWjs. Functions properly on export.
http://bluekeygames.com/replaceColorTest/

Expected Result
"Replace Color" effect should display properly in preview mode for Chrome and NWjs as it does on export or in Edge/IE.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (untested)
  • Internet Explorer: (NO)
  • Edge: (NO)

Operating System and Service Pack
Windows 10, 1607
Chrome 57.0.2987.133

Construct 2 Version ID
r243
B
95
S
35
G
8
Posts: 316
Reputation: 11,328

Post » Tue Apr 18, 2017 4:31 pm

Works fine for me here in preview mode with NW.js and Chrome 57.

Are you sure WebGL is enabled at runtime? Try displaying a text object set to the expression 'renderer'. If your system does not support WebGL, it won't display WebGL effects.
Scirra Founder
B
402
S
238
G
89
Posts: 24,637
Reputation: 196,071


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest