Reprodicable crash in Layout view

Bugs will be moved here once resolved.

Post » Sat Sep 17, 2011 5:30 pm

Hi

Trying to make a quick 'Breakout' type game as a test, and C2 crashes every time I do the following:

Open THIS file in C2, use CTRL+Wheel to zoom in to paddle/ball area and align ball with top of paddle. Whilst the ball is still selected, click the 'Save' icon. This causes my Visual Studio JIT debugger to pop up every time.

Any chance of some kind soul trying this out for me?

Regards

zen
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,838
Reputation: 48,277

Post » Sat Sep 17, 2011 5:38 pm

Work's fine for me :/
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Sat Sep 17, 2011 5:54 pm

Works fine for me on r56, Windows 7. I just nudged the ball down a bit and hit save. Did I do something wrong?
Scirra Founder
B
357
S
214
G
72
Posts: 22,945
Reputation: 178,206

Post » Sat Sep 17, 2011 6:19 pm

I don't get it. Crashes every time for me, as shown below:

zenox982011-09-17 18:20:02
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,838
Reputation: 48,277

Post » Sat Sep 17, 2011 6:21 pm

If you click Yes, does Visual Studio have any useful information in it? (Lucky you have it installed!)
Scirra Founder
B
357
S
214
G
72
Posts: 22,945
Reputation: 178,206

Post » Sat Sep 17, 2011 6:26 pm

This is from VS:



Also noticed this slight screen corruption - don't know if it's relevant:

If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,838
Reputation: 48,277

Post » Sat Sep 17, 2011 6:36 pm

It's not corruption, it's an instance of tha paddle sprite :)
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Sat Sep 17, 2011 6:42 pm

:)

Doh!
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,838
Reputation: 48,277

Post » Tue Sep 20, 2011 11:45 am

** Update **

Now on build R57, and this .capx stills either shuts down with no message or throws the JIT debugger, when trying to save.

All other .capx (demos, downloads and self-tests), and a newly started breakout .capx are working perfectly.

I think I'm giving up on this as an 'X-File' and moving on.

zen
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,838
Reputation: 48,277

Post » Tue Sep 20, 2011 2:47 pm

I don't think anyone else can reproduce it, so there's a chance it's an issue with your machine or as you say a one-off... but looking at the stack trace you posted I'm not so sure. Keep an eye out for similar issues and I'll take a second look if it comes up again.
Scirra Founder
B
357
S
214
G
72
Posts: 22,945
Reputation: 178,206

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests