Rotated Sprite Font gets cut off

Bugs will be moved here once resolved.

Post » Wed Aug 17, 2016 11:05 pm

Problem Description
Sprite Font does not show the entire text in various situations. Bug relates only to rotated Sprite Font.
* Does not show entire text if at particular angle (on some does on some doesn't).
* Does not show entite text if near the screen border (this also behaves differently, details below)

Attach a Capx
https://drive.google.com/file/d/0BwT_0lczDpc9TmE2Y1NkNzMxS1E/view?usp=sharing

Description of Capx
In capx there's a Sprite Font object with Drag&Drop behaviour to easily test the problem.

Steps to Reproduce Bug

test1
  • Start project as it is
  • Drag text up (text will appear)

test 2
  • Go to "game" event sheet and enable first "on start of layout" condition
  • Start project
  • Drag text down (text will dissapear)

test 3
  • Go to "game" event sheet and enable second "on start of layout" condition
  • Start project
  • Drag text around (problem is gone)

test 4
  • Start project
  • Resize browser window to be smaller (text appears)


Observed Result
Second line of text (dis)appears - depends on the test.

Expected Result
All text lines should be visible.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
Windows 10

Construct 2 Version ID
r233 64bit
ImageImageImage
B
27
S
16
G
74
Posts: 977
Reputation: 41,673

Post » Sat Aug 20, 2016 10:38 am

Can I ask for any estimation on this one?
Thanks
ImageImageImage
B
27
S
16
G
74
Posts: 977
Reputation: 41,673

Post » Sat Aug 20, 2016 1:56 pm

I noticed it behaves a little differently when you have webgl disabled.
Image ImageImage
B
169
S
50
G
169
Posts: 8,286
Reputation: 108,216

Post » Wed Aug 24, 2016 11:37 am

@Ashley can I ask for any info? Will this be fixed in the near future or I need to find a workaround? I have project blocked cause of this bug, so any info is appreciated.
ImageImageImage
B
27
S
16
G
74
Posts: 977
Reputation: 41,673

Post » Wed Aug 24, 2016 1:09 pm

B
33
S
18
G
28
Posts: 2,493
Reputation: 20,950

Post » Wed Aug 24, 2016 1:21 pm

Yes I saw this but I thiught it was fixed, but broken again by mistake, and if Ashley managed to fix it before he might be able to fix it quickly again (as he knows the problem already).
ImageImageImage
B
27
S
16
G
74
Posts: 977
Reputation: 41,673

Post » Wed Aug 31, 2016 2:33 pm

Should be fixed in the next build.
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests