Run layout button is disabled after closing projec

Bugs will be moved here once resolved.

Post » Sat Sep 15, 2012 9:21 pm

As far as I can tell, the Run layout button in the upper left corner never works properly after a project is closed from the workspace. Specifically, follow these steps to reproduce:


  1. Open Construct 2

  2. Load any project (Run layout is enabled; as expected)

  3. Load any other project (Run layout is disabled; not ideal, but not a bug per se since the "active project" is no longer necessarily defined)

  4. Run one of the projects by right-clicking on it in the Project explorer (Run layout is now enabled; as expected)

  5. Close either project

  6. Run layout is now disabled



I'd really like to justify buying Construct 2, but I think this is the buggiest product of this scale that I've used (except for video editing software a decade ago)
B
3
Posts: 6
Reputation: 337

Post » Sat Sep 15, 2012 10:41 pm

If you close a project and it is left on an event sheet view, Construct 2 doesn't know which layout from the project to use when previewing.

If you switch to a layout the button then enables and you can preview the other project again normally. This is by design. Does that make sense or do you find that the button does not enable even if you switch to a layout?
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Sun Sep 16, 2012 7:46 am

Hmm, yes, the behavior is exactly as you describe. It sounds as if the behavior is intended so I withdraw the bug report, but it still seems as if the button should enable when there is only one thing that could possibly be run (a single layout in a single project). So, feature request: it would be nice (in my opinion) if the button would always be enabled even when it is ambiguous which project should be run. In the ambiguous cases, it could simply pick one based on whatever algorithm seems most appropriate. Of course, I place much less importance on feature requests than bug reports.

Thanks for the response!
B
3
Posts: 6
Reputation: 337


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests