Runing animation

Get help using Construct 2

Post » Thu Nov 24, 2011 7:45 pm

Hello.

I would be grateful if you could help me to correct this :

I find an animation for an character ,i added it to the game,it works but when i press simultanly some keys it dosen't work.

When i press left arrow and right arrow it runs on place .
When i press right arrow and then i press left arrow and i release the right arrow it runs backward.
B
3
G
1
Posts: 17
Reputation: 584

Post » Thu Nov 24, 2011 7:51 pm

A capx would be helpful to reproduce.
B
33
S
7
G
6
Posts: 34
Reputation: 4,815

Post » Thu Nov 24, 2011 8:49 pm

http://www.2shared.com/file/Rx0lM4Bj/proiect1.html
Thankyou.
B
3
G
1
Posts: 17
Reputation: 584

Post » Thu Nov 24, 2011 9:28 pm

Fixed
http://www.2shared.com/file/GNBnxsSL/Project1Fixed.html
B
22
S
3
G
6
Posts: 52
Reputation: 4,387

Post » Fri Nov 25, 2011 12:37 pm

Thankyou.
B
3
G
1
Posts: 17
Reputation: 584

Post » Fri Nov 25, 2011 12:41 pm

How did you fix it?
B
3
G
1
Posts: 17
Reputation: 584

Post » Fri Nov 25, 2011 3:22 pm

If you look in the code area i just switched out the "Keyboard on pressed" to "While button is down".
B
22
S
3
G
6
Posts: 52
Reputation: 4,387

Post » Fri Nov 25, 2011 4:34 pm

aaaa thankyou
B
3
G
1
Posts: 17
Reputation: 584

Post » Fri Nov 25, 2011 5:08 pm

No problem, glad to help.
B
22
S
3
G
6
Posts: 52
Reputation: 4,387


Return to How do I....?

Who is online

Users browsing this forum: 99Instances2Go, abdalghani, Aurora Australis, imothep85, Marxally, Virpoja and 27 guests