Running My Game

Bugs will be moved here once resolved.

Post » Sun Dec 15, 2013 7:19 pm

I also have a question... when I post my game what if someone steals my idea or something? I mean this is just a demo to see if I'd enjoy programming and learn construct2. I'm pretty amateur.
B
2
Posts: 6
Reputation: 162

Post » Sun Dec 15, 2013 7:26 pm

That's why you should always follow the guidelines when posting in this section. It should be a minimum .capx with clear instructions and steps on re-creating the bug.

Remember. This section is for suspected bugs in the Program itself, and not for problems with understanding or programming errors from the user. There is the 'How Do I' section for those posts.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,556
Reputation: 60,456

Post » Sun Dec 15, 2013 8:06 pm

Actually tried to recreate this in a new project and I can't replicate what you've done.

Strange.

A new pair of eyes would be helpful.zenox982013-12-15 20:41:05
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,556
Reputation: 60,456

Post » Sun Dec 15, 2013 9:10 pm

Nothing looks like it should cause the player's acceleration to run away to infinity and then for the platform top speed to be ignored, but there you go.... It happens. I also can't reproduce it when starting a new project.
A big fan of JavaScript.
B
76
S
20
G
76
Posts: 2,286
Reputation: 47,556

Post » Sun Dec 15, 2013 9:12 pm

@HelicopterDrops

It's because of the Anchor behavior on the ground. Once that's removed, everything is as it should be.

I have no idea why you would want to put the anchor behavior on the ground- it's certainly not needed.zenox982013-12-15 21:12:59
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,556
Reputation: 60,456

Post » Sun Dec 15, 2013 10:10 pm

I actually just read the post on how to post a bug sorry about that.. I also didn't realize there was a second page so I couldn't find the replies but thank you guys for helping me. It's not teleporting me anymore so I'm very grateful. It turns out the problem was the anchor behavior I put on the ground. I have no idea what anchor does. I thought it would just make sure the ground was anchored that's why I put it but lesson learned thanks for helping once again.
B
2
Posts: 6
Reputation: 162

Post » Sun Dec 15, 2013 10:16 pm

Honestly, the best thing to do is post in the 'How Do I' section first.

That way, we can all evaluate whether it is a true bug, or just conflicting events/behaviors.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,556
Reputation: 60,456

Post » Tue Dec 17, 2013 2:21 pm

Closing, please follow the bug report guidelines. Please remember most bug reports by new users are just mistakes and not bugs.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests