Safari sound doesn't work

Discussion and feedback on Construct 2

Post » Thu Oct 18, 2012 12:38 pm

Safari mobile sound doesn't work when a game is hosted in my website, but it works well in Preview on LAN with the initial touch event trick.Someone have the same issue?I have the same problem with all the games i tested including Space blaster touch.
By the way here's a pdf i found, it can be useful for someone
tks

Overcoming iOS HTML5 audio limitationscesisco2012-10-18 12:39:18
B
33
S
11
G
9
Posts: 381
Reputation: 10,153

Post » Thu Oct 18, 2012 10:20 pm

Please someone who have an iPad with iOS 6 just tell me if the sound works when a game hosted in a website or not.All the audio play well when i preview on LAN but the same game when exported doesn't work anymore even space blaster.I have all the settings on, from volume to sound effects in iPad.I would be grateful because i am digging into this all day.
Thanks.
B
33
S
11
G
9
Posts: 381
Reputation: 10,153

Post » Fri Oct 19, 2012 12:03 am

Have you set the right MIME type for .m4a files on your server? Otherwise the browser won't load them.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Fri Oct 19, 2012 12:45 am

Thanks Ashley i added ogg and forgot m4a. shame.I never thought it was the mime type because i couldn't ear the sound in iPad as well in space blaster www/scirra/labs/sbmobileweb3/cesisco2012-10-19 00:51:18
B
33
S
11
G
9
Posts: 381
Reputation: 10,153


Return to Construct 2 General

Who is online

Users browsing this forum: chadorireborn and 5 guests