Same Hardware, Different Performance

Discussion and feedback on Construct 2

Post » Sun Aug 23, 2015 8:19 am

Hi all,

Wondering if people have already been talking about this.

I have a macbook pro newest version with integrated graphics. I just installed Bootcamp on it and am running Windows 10 and OSX (latest version).

I exported my game Brute with Node Webkit and ran it in windows, the game ran silky 60fps, no hitches. Which I was very happy to see. Though when I booted up OSX, same machine, ran the mac export of the game and it was <30fps - very slow and choppy.

Is something up with the mac version of Webkit?

Sorry if this has already been addressed? Have looked on the forums but not found anything specific to contrasting performance on exactly the same hardware.
B
44
S
13
G
8
Posts: 622
Reputation: 7,417

Post » Sun Aug 23, 2015 5:25 pm

The Windows graphics drivers may be significantly better quality than the OS X drivers. What does chrome://gpu say when running Chrome on OS X?
Scirra Founder
B
398
S
236
G
88
Posts: 24,442
Reputation: 194,683

Post » Mon Aug 24, 2015 6:57 am

@Ashley

The performance on OSX in Chrome is a rock solid 60 FPS, it's just webkit which is very poor.

chrome://gpu says - well I don't know what aspects you want so I've put it in a text file here:

https://docs.google.com/document/d/1iszn30j2IX3_VjniMeVO5qGBA4NJLWst-QXOcIHf4Os/edit?usp=sharing
B
44
S
13
G
8
Posts: 622
Reputation: 7,417

Post » Mon Aug 24, 2015 10:38 am

Oh, right - then I'd chalk this up to NW.js being a few versions behind Chrome (v0.10.5 is particularly old now too). I guess it's a problem already fixed in Chromium and it should be fixed when NW.js catches up to Chrome.
Scirra Founder
B
398
S
236
G
88
Posts: 24,442
Reputation: 194,683

Post » Mon Aug 24, 2015 11:43 am

@ashley - that makes sense, thanks Ash.
B
44
S
13
G
8
Posts: 622
Reputation: 7,417


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 8 guests