Saving system not working on Chrome and Opera

Bugs will be moved here once resolved.

Post » Fri Aug 04, 2017 2:33 pm

Problem Description
Saving/Loading doesn't work

Attach a Capx
https://cdn.discordapp.com/attachments/ ... adBug.capx

Description of Capx
It's just the platformer template.

Steps to Reproduce Bug
  • Open Debugger and console
  • Save
  • Load

Observed Result
This:
Image
The save saves to IndexedDB Storage (2337bytes of data) but the load loads from WebStorage where there is 0 byte
This only happens on Chrome and Opera. All the other browsers I listed correctly loads from IndexedDB Storage

Expected Result
Loading should load the saved data

Affected Browsers
  • Chrome: (YES)
  • Opera: (YES)
  • FireFox: (NO)
  • Internet Explorer: (NO)
  • Edge: (NO)
  • NW.JS: (NO)

Operating System and Service Pack
Windows 10

Construct 2 Version ID
r245
My addons:
[PLUGIN]Value Monitor
[PLUGIN] Text Alignement
[BEHAVIOR]Timescale Ratio
[BEHAVIOR]Polar Coordinates
[PLUGIN]Action Sequence
[BEHAVIOR]Action Sequence
[BEHAVIOR]Instance Variable Control
B
36
S
7
G
2
Posts: 230
Reputation: 3,517

Post » Fri Sep 15, 2017 2:35 pm

Can't reproduce, works for me here in Chrome. Are you sure you're not out of storage quota or something?
Scirra Founder
B
403
S
238
G
89
Posts: 24,654
Reputation: 196,155

Post » Sat Sep 16, 2017 8:19 am

Yeah, that was it. I reinstalled Chrome after trying to clear cache and storage etc, and it worked again fine. Thanks
My addons:
[PLUGIN]Value Monitor
[PLUGIN] Text Alignement
[BEHAVIOR]Timescale Ratio
[BEHAVIOR]Polar Coordinates
[PLUGIN]Action Sequence
[BEHAVIOR]Action Sequence
[BEHAVIOR]Instance Variable Control
B
36
S
7
G
2
Posts: 230
Reputation: 3,517


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 8 guests