Screen flashing with NWjs / Audio related

Discussion and feedback on Construct 2

Post » Wed Oct 12, 2016 11:11 am

Yeah I am using v0.13.2 all the time now. Using any newer version is simply not acceptible because of this flickering.

Just remember to not overwrite the NWjs installation, but remove the current one first (simply delete files) and install v0.13.2. Otherwise you'll have problems with huge Mac version export size.
ImageImageImage
B
27
S
16
G
74
Posts: 977
Reputation: 41,673

Post » Wed Oct 26, 2016 5:34 am

I'm also having the same issue, had to take a bit of time off of C2, so i just noticed it, very annoying. Will try rolling back to v.13.1.2 as version 0.18.1 still has the same issue. thanks for the heads up
B
56
S
17
G
5
Posts: 184
Reputation: 8,908

Post » Wed Oct 26, 2016 5:38 am

Rolling back worked for me.
Image
B
74
S
28
G
12
Posts: 515
Reputation: 12,359

Post » Wed Oct 26, 2016 8:11 am

Did someone who currently has to deal with these issues, test out if it's still occurring in the recent versions of C2 (r239) and NWjs (v0.18.1)?
ImageImageImage
B
60
S
22
G
78
Posts: 646
Reputation: 44,730

Post » Tue Nov 01, 2016 1:24 am

TheRealDannyyy wrote:Did someone who currently has to deal with these issues, test out if it's still occurring in the recent versions of C2 (r239) and NWjs (v0.18.1)?


It works fine with NWjs 0.18.1. I have no flickering any more.

0.13.x - no flickering
0.14.x to 0.17.x - gives flickering
0.18.x - no flickering

I tested it only for around 10 minutes, but usually it started flickering within a minute, so I'm pretty sure it's fixed.
ImageImageImage
B
27
S
16
G
74
Posts: 977
Reputation: 41,673

Post » Tue Nov 01, 2016 3:08 am

I'm still getting the flickering even after the most recent updates. It's really random for me tho. It will happen multiple times in a minute and then not happen at all until I run another preview. Only happens in fullscreen for me.
B
42
S
11
G
1
Posts: 264
Reputation: 3,299

Post » Tue Nov 01, 2016 1:30 pm

I rolled back to 0.13. No flickering.
B
42
S
11
G
1
Posts: 264
Reputation: 3,299

Post » Tue Nov 01, 2016 4:55 pm

BackendFreak wrote:It works fine with NWjs 0.18.1. I have no flickering any more.
0.13.x - no flickering
0.14.x to 0.17.x - gives flickering
0.18.x - no flickering
I tested it only for around 10 minutes, but usually it started flickering within a minute, so I'm pretty sure it's fixed.

I think you got a game on Steam right (congrats btw), might want to check out their reviews.
The more different setups we test this on, the better we can identify and hopefully find a fix for this bug.


bclikesyou wrote:I rolled back to 0.13. No flickering.

I'm not on Ashley's level when it comes to things with the web but I've had similar issues to this one in the past with native software and directX.
For me this all sounds like there is something terribly wrong with the drivers, this doesn't necessarily mean that you guys are at fault.
No, it might be more of a bug from NWjs's side of things, however if that would be the case then you'd also experience this in Chrome itself.

I would like to request a basic example.capx where this bug is occurring so that I (and maybe others) could investigate it.
If you got some free time, I'd very much appreciate if you could share the following helpful information:
  • Basic info about your graphics and cpu drivers
  • Any 3rd party plugins that you use, even if they don't seem to be related to this
  • The content of all 3 package.json files found in your nwjs folder (X:\xxx\Construct2\Construct2-Win64\exporters\html5\nwjs)
    You can upload those files to make things simple, they are just about 3KB big.

What you also could do right away is to clean install the latest version of NWjs.
At first use the uninstaller and then go back to the actual folder and delete everything that's left (nwjsforC2 folder only).
As useless as this sounds, I had my fair share of "experiences" with NWjs and I got them fixed by exactly doing that twice already.

Thanks for your time and looking forward to the helpful information.
ImageImageImage
B
60
S
22
G
78
Posts: 646
Reputation: 44,730

Post » Tue Nov 01, 2016 11:52 pm

TheRealDannyyy wrote:I think you got a game on Steam right (congrats btw), might want to check out their reviews.
The more different setups we test this on, the better we can identify and hopefully find a fix for this bug.

Thanks. I've released it with NWjs 0.13.2, so there will most probably be no feedback regarding this flickering. I'm busy with other things now, but once I'm done I'll try to replicate it and simplify capx as much as possible. We'll see if we can identify the issue. I think it is purely NWjs issue. There's no flickering when you test in Chrome. But I'm not an expert and as NWjs team ignored this issue stating it's not their fault, then maybe it's not. They know more than me. And it's also weird that it's related to the Audio plugin. I'll update the capx when I'm done.

bclikesyou wrote:I'm still getting the flickering even after the most recent updates.

Hmm... I'll surely give it some more tests. Thanks.
ImageImageImage
B
27
S
16
G
74
Posts: 977
Reputation: 41,673

Post » Wed Nov 02, 2016 12:05 am

BackendFreak wrote:Thanks. I've released it with NWjs 0.13.2, so there will most probably be no feedback regarding this flickering. I'm busy with other things now, but once I'm done I'll try to replicate it and simplify capx as much as possible. We'll see if we can identify the issue. I think it is purely NWjs issue. There's no flickering when you test in Chrome. But I'm not an expert and as NWjs team ignored this issue stating it's not their fault, then maybe it's not. They know more than me. And it's also weird that it's related to the Audio plugin. I'll update the capx when I'm done.

OK sounds like the classic case of passing the blame, if the problem persists in the newer versions (v19+) I will start another bug report on their git.
They won't be able to get rid of me that easily. 8-)

Anyway, do you have the link to the report for me? I'd like to check it out by myself.
ImageImageImage
B
60
S
22
G
78
Posts: 646
Reputation: 44,730

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 8 guests