ScrollTo Bug?

Bugs will be moved here once resolved.

Post » Mon Apr 15, 2013 7:21 pm

Link to .capx file:
Download .capx

Steps to reproduce:
1. Use Mouse to aplly force
2. Just move Forward

Observed result:
The "player" collides with an invisible wall. And after some time applying force forward, he passes through, but the ScrollTo Behavior does not work.
If i remove the ScrollTo behavior, the invisible wall disapears.


Expected result:
The scroll behavior working, and no invisible walls.

Browsers affected:
Chrome: yes
Internet Explorer: yes

Operating system & service pack:

Windows 7

Construct 2 version:
   r125
B
17
S
3
G
1
Posts: 19
Reputation: 1,940

Post » Mon Apr 15, 2013 8:33 pm

Everything is working fine, when the layout scrolls forward, the ship seems to collide with an invisible wall and stay put, but actually the layout scrolls forward all the time. Here, I drew a line on the canvas so you could understand.

http://www.upload.ee/files/3236297/Test_Sub.capx.html
B
14
S
5
G
4
Posts: 107
Reputation: 4,758

Post » Mon Apr 15, 2013 9:25 pm

I realized that some time ago, tottaly forgot the bg. I cant believe i'm that dumb

But thanks for the help. xD
B
17
S
3
G
1
Posts: 19
Reputation: 1,940

Post » Mon Apr 15, 2013 10:28 pm

Closing, and ugh, please never use MediaFire, it's got so many adverts with fake download buttons I have to hunt for the real one. Use Dropbox, it's way better!
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,468


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests