Security alert in Play Store who get this

Discussion and feedback on Construct 2

Post » Tue Feb 09, 2016 12:10 am

Who get this alert in there Google play console
Security alert
Your app is using a version of Apache Cordova containing one or more security vulnerabilities. Please see this Google Help Center article for details, including the deadline for fixing the app.

https://support.google.com/faqs/answer/6325474

who is at fault Construct 2 or intel xdk because people who build with cli 4.1.2 up to 5.1.1 get the same alert i am lost :!:
Image
B
42
S
13
G
2
Posts: 329
Reputation: 4,085

Post » Tue Feb 09, 2016 3:32 am

I got it today as well.

My theory is that Scirra has to update the Cordova exporter... I don't really know though.

@ashley, any thoughts?
Risk Rocket now available on Google Play
Image
B
36
S
15
G
6
Posts: 337
Reputation: 6,300

Post » Tue Feb 09, 2016 3:54 am

Seems to be Intel: https://software.intel.com/en-us/xdk/do ... -intel-xdk (search for 4.1.0)
If you look in the files C2 generates, there is no versioning of Cordova mentioned, only the cordova.js file is referenced, but it is Intel that adds that file.
ImageImageImage
B
71
S
22
G
259
Posts: 3,793
Reputation: 143,702

Post » Tue Feb 09, 2016 4:34 am

I also got this. How do we update Apache Cordova @Ashley ?
The Things you can create is only limited by your imagination. If you don't have the skills then use your motivation as a natural force to exceed all expectations. Chadori RebornXD
B
67
S
22
G
90
Posts: 1,125
Reputation: 60,036

Post » Tue Feb 09, 2016 5:01 am

The same thing goes for me. It says if you have more than 20 apps with same issue you must update the Apache Cordova?
ImageImage
B
115
S
51
G
24
Posts: 790
Reputation: 23,505

Post » Tue Feb 09, 2016 7:48 am

i do some check from what i read the problem is not with construct 2 but it is with the wrapper that you use to compile your .apk like intel xdk, cocoon cloud etc... i know cocoon is running 4.0.2 and intel going stop use 4.1.2 by march or may 2016 so it is nothing to worry about becuase i was until found out that it was the apk wrapper. :)
Image
B
42
S
13
G
2
Posts: 329
Reputation: 4,085

Post » Tue Feb 09, 2016 8:09 am

Hi!
This issue has nothing to do with Construct 2. Intel XDK and CocoonIO just use older Cordova versions for their compilers.
Intel and Ludei will update their compilers. Up to now this warning has no affect on your games.

Just be patient and give Intel and Ludei some time to migrate a newer version to their compilers ;)

Regards
Andy
Image Image iTunes: Match3 | Google Play: Match3
B
109
S
39
G
31
Posts: 1,175
Reputation: 29,314

Post » Tue Feb 09, 2016 8:22 am

I have same problems :( , when we can update it? i build with crosswalk intel xdk. How do we update Apache Cordova @Ashley
B
3
Posts: 4
Reputation: 183

Post » Tue Feb 09, 2016 9:53 am

smartyangelanlee wrote:I have same problems :( , when we can update it? i build with crosswalk intel xdk. How do we update Apache Cordova @Ashley


We as users and ashley don't. It's up to Intel and Ludei... just be patient!
Image Image iTunes: Match3 | Google Play: Match3
B
109
S
39
G
31
Posts: 1,175
Reputation: 29,314

Post » Tue Feb 09, 2016 9:56 am

I have the same problem
B
10
S
2
Posts: 71
Reputation: 696

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 15 guests