Security alert in Play Store who get this

Discussion and feedback on Construct 2

Post » Tue Feb 09, 2016 10:28 am

Message: DannyBil can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
The CLI version number does not equal the Apache Cordova version number. For details regarding Intel XDK CLI version numbers and the corresponding Apache Cordova version numbers, please read this FAQ > Why does the Cordova version number not match the Projects tab's Build Settings, the Emulate tab, App Preview and my built app?
Our Cordova CLI 4.1.2 build system is "pinned" to:
[email protected] (Android Cordova framework version 3.6.4)
[email protected] (iOS Cordova framework version 3.7.0)
[email protected] (Cordova Windows framework version 3.7.0)
Our Cordova CLI 5.1.1 build system is "pinned" to:
[email protected]
[email protected]
[email protected]
Our upcoming Cordova CLI 5.4.1 build system is expected to be "pinned" to:
[email protected]
[email protected]
[email protected]
Our upcoming CLI 5.4.1 build system should probably be called "CLI 5.4.1+" because it is closer to the "pinned" versions for Cordova CLI 6.0.0 than to those "pinned" in the official CLI 5.4.1 release.
•For those versions of Crosswalk that are built with the Intel XDK CLI 4.1.2 build system, the cordova-android version of the Cordova framework is determined by the Crosswalk project, not by the Intel XDK build system.
https://software.intel.com/en-us/xdk/fa ... va-version
B
9
S
4
Posts: 6
Reputation: 737

Post » Tue Feb 09, 2016 11:00 am

So we can't use Intel SDK at all? No app compiled with Intel SDK can be approved in GooglePlay?
B
10
S
2
Posts: 71
Reputation: 696

Post » Tue Feb 09, 2016 11:24 am

B
10
S
2
Posts: 71
Reputation: 696

Post » Tue Feb 09, 2016 11:38 am

Nothing to worry about guys i was but i understand it now

they are stating that you will not be able to publish apps or updates to apps built with less than [email protected] beginning May 9, 2016. Your existing published versions will remain available in the store after that date, and any updates you apply to your apps before that time will also be available in the store

when a update come out the only thing we Dev have to do is just rebuild our game
example Sudoku Nano version 1.2.0 just update it to Sudoku Nano version 1.2.1 when intel or cocoon or whoever upgrade there compiler before May 9, 2016
Image
B
38
S
11
G
2
Posts: 315
Reputation: 3,797

Post » Tue Feb 09, 2016 11:42 am

wizdigitech wrote:Nothing to worry about guys i was but i understand it now

they are stating that you will not be able to publish apps or updates to apps built with less than [email protected] beginning May 9, 2016. Your existing published versions will remain available in the store after that date, and any updates you apply to your apps before that time will also be available in the store

when a update come out the only thing we Dev have to do is just rebuild our game
example Sudoku Nano version 1.2.0 just update it to Sudoku Nano version 1.2.1 when intel or cocoon or whoever upgrade there compiler before May 9, 2016


Exactly, you got the point ;)
Image Image iTunes: Match3 | Google Play: Match3
B
100
S
35
G
30
Posts: 1,137
Reputation: 28,087

Post » Tue Feb 09, 2016 12:38 pm

As others have noted, C2 doesn't specify a Cordova version - it should use whichever is the latest. So just rebuilding your app should fix this, provided the build system is using a new enough Cordova version. If the build system isn't updated yet, I'm sure they'll be on it soon, since they will be inundated with reports from everyone who uses it!

FWIW, this seems to happen from time to time on Google Play - Google are pretty pro-active about weeding out any apps that use any libraries with known vulnerabilities.
Scirra Founder
B
398
S
236
G
88
Posts: 24,441
Reputation: 194,661

Post » Tue Feb 09, 2016 12:42 pm

Any idea when IntelXDK will be using a newer version of Cordova? I have been getting these security emails for over a year now.

I just published 3 new apps (all within the last month) and each one of them got this security warning.
B
44
S
18
G
8
Posts: 501
Reputation: 8,472

Post » Tue Feb 09, 2016 5:11 pm

As always scirra say : its not us !! Its your problem
B
16
S
6
Posts: 243
Reputation: 1,755

Post » Tue Feb 09, 2016 5:49 pm

mahdi71 wrote:As always scirra say : its not us !! Its your problem


In this case, it is not scirra. Scirra is not building it with cordova, can't blame them for something a third party is adding on.
B
44
S
18
G
8
Posts: 501
Reputation: 8,472

Post » Tue Feb 09, 2016 5:56 pm

mahdi71 wrote:As always scirra say : its not us !! Its your problem


Probably because it is not Scirra that makes the cordova, but I don't see any reason to panic as I'm quite sure that both xdk and cocoon will fix this well within the time limit that google play has told us.
B
32
S
10
G
6
Posts: 259
Reputation: 6,776

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: Tjums and 13 guests