Security alert in Play Store who get this

Discussion and feedback on Construct 2

Post » Tue Feb 09, 2016 6:37 pm

Basically, Intel needs to release CLI version 5.4.1 to correct the issue. Don't know the timeframe on when they're gonna release that. We're currently on 5.1.1 which has an outdated version of Cordova..
Image
B
82
S
16
G
4
Posts: 503
Reputation: 8,978

Post » Tue Feb 09, 2016 6:47 pm

This is the link that Google Play gave me:
https://support.google.com/faqs/answer/6325474
B
92
S
30
G
11
Posts: 654
Reputation: 11,707

Post » Tue Feb 09, 2016 6:54 pm

Here's the problem: Google Play states the following in the email (I also got the email) :

While these specific issues may not affect every app that uses Apache Cordova, it’s best to stay up to date on all security patches. Apps with vulnerabilities that expose users to risk of compromise may be considered Dangerous Products in violation of the Content Policy and section 4.4 of the Developer Distribution Agreement.

So if you don't update your apps, technically you could get a Google Play account strike after May 2016.

Here's the kicker; I've updated apps in the past for similar issues and the update launches another verification of your app. During that verification there is a reasonable chance that your app will get flagged for a totally unrelated issue and generate a policy strike. It happened to me last time. A 2-year old app got a policy strike for something it was not violating.

So, do we feel lucky? ;)
B
15
S
2
Posts: 229
Reputation: 1,353

Post » Tue Feb 09, 2016 6:55 pm

Iolva wrote:This is the link that Google Play gave me:
https://support.google.com/faqs/answer/6325474


That link is useless.
Once again, it's nothing that we can do until Intel updates XDK with an updated version of CLI that has an updated version of Cordova.
Image
B
82
S
16
G
4
Posts: 503
Reputation: 8,978

Post » Tue Feb 09, 2016 9:09 pm

mahdi71 wrote:As always scirra say : its not us !! Its your problem

No need to worry. This has happened before and was fixed by Intel (since it's their job to fix this) and I was able to rebuild.
B
135
S
33
G
17
Posts: 1,559
Reputation: 20,732

Post » Wed Feb 10, 2016 10:33 am

This is so weird everyone imagine if you have like around 100 apps on the market and if this thing happens again in the future we will need to update all of our 100 apps?? Anyway at least let's hope Intel and Ludei updates their wrapper as soon as possible. Btw does anyone know how will we ever know when they are updated??
B
19
S
6
Posts: 179
Reputation: 2,202

Post » Wed Feb 10, 2016 11:23 am

volcank wrote:This is so weird everyone imagine if you have like around 100 apps on the market and if this thing happens again in the future we will need to update all of our 100 apps??

Yes :) And be at ease, if you are a web designer and you have 100 clients who requested WordPress sites from you and one day someone finds a vunerability inside WordPress you would have to update all 100 sites (if you still work for them). Since it's just a rebuild, unless you use lot's of plugins, you can expect everything to work just fine.
B
135
S
33
G
17
Posts: 1,559
Reputation: 20,732

Post » Thu Feb 11, 2016 10:09 am

Ludei has updated their compiler ;)

Regards
Andy
Image Image iTunes: Match3 | Google Play: Match3
B
102
S
37
G
31
Posts: 1,164
Reputation: 28,883

Post » Thu Feb 11, 2016 1:48 pm

AndreasR wrote:Ludei has updated their compiler ;)

Regards
Andy


Dude Ludei is free complier like intel xdk or not ? please advise
B
15
S
5
G
3
Posts: 72
Reputation: 2,645

Post » Thu Feb 11, 2016 2:22 pm

I guess some people take a look on the progress with Intel XDK's version of the compiler from time to time.
It would be really appreciated if someone could keep us up to date, if this is gets fixed later on and post it here. :)
ImageImageImage
B
63
S
23
G
78
Posts: 664
Reputation: 44,941

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 6 guests