[Semi-Solved]-[R73] Mouse Over Sprite

Bugs will be moved here once resolved.

Post » Mon Jan 02, 2012 9:02 am

When you mouse over a sprite, it will not act as expected. The "zone" of the sprite seems to be some randomly chosen (if at all, in some cases it won't work at all!) area within or near the object that will activate the action.

See capx: DOWNLOAD

Simply move your mouse over the iphone, to make it change animation frames. Notice that it only works when you are near the centre of the object, but not near the edges. In my project, this particular object doesn't even work at all, but in this new example it at least works to some degree.

Hopefully it's an easy fix.

~SolSoldjahBoy2012-01-02 09:46:52
Tired of crappy file hosts that are crappy? Get DROPBOX - https://db.tt/uwjysXJF
Moderator
B
45
S
17
G
37
Posts: 2,853
Reputation: 25,966

Post » Mon Jan 02, 2012 9:19 am

If the collision box for the second frame is set to Bounding box like the first, then it works ok.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,840
Reputation: 48,281

Post » Mon Jan 02, 2012 9:46 am

FFFFFFFFFFFFFFFFFFFFFwha?

*checking now*

You're right. It now works just fine. The collision mask for frame two was set to some weird and random triangle off in the bottom corner of the frame.

Why was this not a problem in the past?

{SOLVED} - Thanks Zenox98

~Sol
Tired of crappy file hosts that are crappy? Get DROPBOX - https://db.tt/uwjysXJF
Moderator
B
45
S
17
G
37
Posts: 2,853
Reputation: 25,966


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests