Series of javascript erros makes game unrunnable

Bugs will be moved here once resolved.

Post » Wed Feb 13, 2013 3:21 am

Steps to reproduce:
1. Press preview

Observed result:
These errors appear in pop-ups.

Viewport target-densitydpi is not supported. localhost:11
Uncaught SyntaxError: Unexpected token ILLEGAL data.js:1333
Uncaught TypeError: Object #<Object> has no method 'getProjectModel' preview.js:652
Uncaught TypeError: Cannot call method 'runWaits' of undefined preview.js:1439

Expected result:
Not... those errors

Browsers affected:
Chrome: yes
Internet Explorer: yes/no

Operating system & service pack:
Windows 7

    
B
20
S
10
G
4
Posts: 106
Reputation: 4,219

Post » Wed Feb 13, 2013 3:11 pm

Does this happen all the time, even with a new empty project? Did you test Firefox? If you press 'refresh' does the game then load? Have you had a look at troubleshooting Construct 2's preview server?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Thu Feb 14, 2013 3:12 am

That preview troubleshooting this looks very useful, but what ended up helping was downloading the latest beta and seeing the errors thrown upthere. Turns out my artist replaced some art files, but accidentally deleted a 000 file.

Thanks for the help!
B
20
S
10
G
4
Posts: 106
Reputation: 4,219

Post » Sun Oct 27, 2013 1:24 pm

What is a 000 file? I'm getting shutout of the preview also.   I'll be looking at Ashley's link.
TYSquirrely12013-10-27 13:29:52
B
16
S
2
G
1
Posts: 35
Reputation: 1,033

Post » Sun Oct 27, 2013 2:43 pm

@Squirrely1 - please post a new report following all the guidelines, or your report will be ignored. This is a closed bug report from February.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sun Oct 27, 2013 11:03 pm

yup. Got it.     I was just searching around. in a rush, not lot of time free.
B
16
S
2
G
1
Posts: 35
Reputation: 1,033


Return to Closed bugs

Who is online

Users browsing this forum: Kenthria and 4 guests