Set Animation Frame [C2] [SOLVED]

Just started using Construct 2? Post your questions here

Post » Sat Jul 15, 2017 11:38 pm

I'm having a devil of a time with this.

Not sure why it isn't working.

All I'm trying to do is create 2 different objects as a test and have them play from 2 different frames.

All I'm doing is:

Trigger once-> Set animation frame 0
->Create object A (which already has the default animation)

Trigger once-> Set animation frame 1
->Create object B (which already has the default animation)

(tried it w/ sub-events too)

Basically I have an engine animation for ships and want the animations to play from alternate frames for each alternate spawn, so they don't look exactly the same.

And nothing is working.

I checked the Scirra manual and like 5 or 6 Google posts - no help.

Also tried it with instance variables, but it didn't work.

I solved this before by doing alternate animations for each frame, but that gets pretty tedious when you have a lot of sprites/animations.

Shouldn't there be an easy way to do this?

What's the proper/working way to use "set animation frame" to have objects play the default animation from different frames when they spawn?

--
Apparently you set the frame after creating the object!
B
37
S
20
G
18
Posts: 259
Reputation: 12,922

Post » Sat Jul 15, 2017 11:50 pm

You set the frame after creating the object. Unless you pasted the logic wrong in here.
B
46
S
16
G
79
Posts: 2,171
Reputation: 46,859


Return to Beginner's Questions

Who is online

Users browsing this forum: No registered users and 3 guests