Setting The Mouse Cursor To "None" Is Not Working (Firefox)

Bugs will be moved here once resolved.

Post » Wed May 03, 2017 1:57 am

Problem Description
As the title says, the action to set the mouse cursor invisible (none) is broken in Firefox.

Attach a Capx
Download the capx there.

Description of Capx
Simple example to reproduce the bug.

Steps to Reproduce Bug
  • Open the capx and enter the preview in Firefox
  • Click on the "none" button
  • Notice that the mouse cursor is still the same

Observed Result
The action to set the mouse cursor to none doesn't seem to work in Firefox.

Expected Result
The mouse cursor should be invisible after clicking on the button.

Affected Browsers
  • Firefox: (YES)
Operating System and Service Pack
Windows 7 with latest updates and up to date drivers.

Construct 2 Version ID
Newest release r244 Steam release. [Personal Edition]
ImageImageImageImage
B
56
S
21
G
77
Posts: 636
Reputation: 43,961

Post » Wed May 03, 2017 3:49 am

works for me. I'm on win 10. and the latest stable ff browser.

try updating your FF browser

"Note: cursor: none; is not supported until Firefox 3, Safari 5, and Chrome 5. Not at all supported in IE or Opera. "
https://css-tricks.com/almanac/properties/c/cursor/
B
25
S
16
G
26
Posts: 125
Reputation: 16,103

Post » Wed May 03, 2017 4:26 am

celstrider wrote:works for me. I'm on win 10. and the latest stable ff browser.

try updating your FF browser

"Note: cursor: none; is not supported until Firefox 3, Safari 5, and Chrome 5. Not at all supported in IE or Opera. "
https://css-tricks.com/almanac/properties/c/cursor/

I did reproduce this in Firefox v53.0 (32-Bit) which is the latest stable build.
Could this perhaps be an OS related issue?
ImageImageImageImage
B
56
S
21
G
77
Posts: 636
Reputation: 43,961

Post » Wed May 03, 2017 5:32 am

I don't know. I just blew the dust off my old windows vista and gave it a try. It didn't work at first but after updating firefox it also works. I don't have a win 7 so I can't check that system.

You could look through you're mouse settings and see if there's anything that maybe interfering. I think some of the windows themes affect the mouse properties too so you could try switching to the basic theme if you aren't already using it. Check if you have any ff plugins that could affect the cursor. Other than that I'm out of ideas.
B
25
S
16
G
26
Posts: 125
Reputation: 16,103

Post » Wed May 03, 2017 7:34 am

celstrider wrote:I don't know. I just blew the dust off my old windows vista and gave it a try. It didn't work at first but after updating firefox it also works. I don't have a win 7 so I can't check that system.

You could look through you're mouse settings and see if there's anything that maybe interfering. I think some of the windows themes affect the mouse properties too so you could try switching to the basic theme if you aren't already using it. Check if you have any ff plugins that could affect the cursor. Other than that I'm out of ideas.

Switched off Aero, disabled script + adblockers and it's still the same.
I really think this is a Firefox on Windows 7 issue but I can't be 100% sure.

Would be nice if other Win7 (64bit) users could check this out and share their results.
ImageImageImageImage
B
56
S
21
G
77
Posts: 636
Reputation: 43,961

Post » Wed May 03, 2017 8:21 am

No problem here with Firefox 53 (32Bit) and Win7(64Bit). Works how it should.
B
24
S
3
G
1
Posts: 451
Reputation: 2,165

Post » Wed May 03, 2017 10:29 am

Asmodean wrote:No problem here with Firefox 53 (32Bit) and Win7(64Bit). Works how it should.

Could you do me a quick favor and playtest this game: https://www.scirra.com/arcade/action-ga ... game-16921
You shouldn't be able to see the mouse cursor at all, however on my end it's there using Firefox.
ImageImageImageImage
B
56
S
21
G
77
Posts: 636
Reputation: 43,961

Post » Wed May 03, 2017 11:13 am

Works like you intended.
The mouse pointer is the lighter spot above the text-bubble. I suppose that is like it should?

Image
B
24
S
3
G
1
Posts: 451
Reputation: 2,165

Post » Wed May 03, 2017 12:11 pm

Asmodean wrote:Works like you intended.
The mouse pointer is the lighter spot above the text-bubble. I suppose that is like it should?

Weird, I guess it's an issue on my end. No clue about the cause of this issue though.
Yeah that's intended behavior by the way. Thanks for testing.
ImageImageImageImage
B
56
S
21
G
77
Posts: 636
Reputation: 43,961

Post » Fri Jun 23, 2017 4:22 pm

Works OK in Firefox here. Note you have to move the mouse off the button to see the correct style; I suppose the button uses its own cursor style (which seems sensible).
Scirra Founder
B
387
S
230
G
88
Posts: 24,251
Reputation: 192,454

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest