Shader Effects

Discussion and feedback on Construct 2

Post » Wed Aug 22, 2012 7:12 pm

I know it's only just come out but I'm noticing that the warp effects aren't working in FF 14.0.1, they work fine in Chrome. Anyone else get this?
B
72
S
25
G
9
Posts: 382
Reputation: 10,649

Post » Wed Aug 22, 2012 7:28 pm

I notice they completely mess up my computer. I can't look at the layout or anything. Drivers are up to date though. The effects work in Chrome but just not in the editor.
B
29
S
4
Posts: 42
Reputation: 2,391

Post » Wed Aug 22, 2012 7:39 pm

Perhaps webgl is not enables in ff on your computer?

To turn it on:
Go to address about:config
type in webgl
set "webgl-force-enabled" to true
B
79
S
24
G
52
Posts: 4,725
Reputation: 39,713

Post » Wed Aug 22, 2012 8:04 pm

Thanks R0J0hound, I assumed because other shaders are working that it was turned on. I've now set "webgl-force-enabled" to true but still no joy. :( Are there any other setting that need turning on?
B
72
S
25
G
9
Posts: 382
Reputation: 10,649

Post » Wed Aug 22, 2012 8:32 pm

Well I'd go with chrome for your testing for now.
The computer I'm on right now has a very old graphics card so webgl shaders don't work at all. It only support opengl 1.4 and I think you need support for at least opengl 2.0 to get shaders working in the editor.

It is probably falling back to canvas2d in firefox. You could try setting "webgl.prefer-native-gl" to true and see if that works. I imagine it will if the effects are working in the editor.
B
79
S
24
G
52
Posts: 4,725
Reputation: 39,713

Post » Wed Aug 22, 2012 8:40 pm

All effects look as they should in the editor. Tried setting "webgl.prefer-native-gl" still no luck. I have a Nvidia GeForce 8800 graphics card and drivers are up to date. Is this hapenning to anyone else?
B
72
S
25
G
9
Posts: 382
Reputation: 10,649

Post » Wed Aug 22, 2012 9:10 pm

I also have OpenGL 3.3.0.
B
72
S
25
G
9
Posts: 382
Reputation: 10,649

Post » Wed Aug 22, 2012 9:23 pm

Create a text object and add an event "start of layout: set text to renderer" and see if it says webgl. If it says canvas2d can you run any other webgl shader demos from around the internet from firefox?
B
79
S
24
G
52
Posts: 4,725
Reputation: 39,713

Post » Wed Aug 22, 2012 9:38 pm

Yup, says 'webgl" for renderer and I can run all the ones from webglplayground.net.Nickydude2012-08-22 21:39:13
B
72
S
25
G
9
Posts: 382
Reputation: 10,649

Post » Wed Aug 22, 2012 10:14 pm

From my quick tests, most webGL fx works in firefox except water.
The image distorts in the editor, it does distort too in chrome, but it doesn't when I preview in FF 14.0.1

Apart from this fx though, the others I've been trying are working.


Edit: I've just tested a combination Glass+GrayScale, and it happens to be flipping the over cog and under texture in the "WebGL shader effects.capx". Not really something I would have expected.
But it does in FF and chrome (in the editor, it only flips the under texture).Kyatric2012-08-22 22:24:36
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791

Next

Return to Construct 2 General

Who is online

Users browsing this forum: 8tomo8 and 11 guests