Silence in loop music

Bugs will be moved here once resolved.

Post » Mon Jan 09, 2017 10:51 am

Problem Description
With preview over wifi in last version of chrome (Android) and in default navegator (Android) and in WebView (Android).

When you play a looped music track there is a delay in the loop.
That is, when the music track ends and have to loop, then there is a silence that breaks with the abmient you want to create.

The correct method would be this:

1 - The track is played
2 - The track ends
3 - The track is played
4 - The track ends
...

But the current method is this:

1 - The track is played
2 - The track ends
3 - There is silence
4 - The track is played
5 - The track ends
6 - There is silence
...

Attach a Capx
https://dl.dropboxusercontent.com/u/60803633/testLoopMusica.capx

Description of Capx
Blank design with a track to be played in loop when a touch in the screen is detected.

Steps to Reproduce Bug
    [1] Touch the screen
    [2] Listen to the silence between the end and the new track playback

Observed Result
A silence exists in the time space in which the track ends and a new playback starts

Expected Result
There should be no silence that breaks the musical environment that is intended to create.

Affected Browsers
  • Last version of Chrome in Android: (YES)
  • Last version of default navigator in Android: (YES)
  • WebView Android: (YES)

Operating System and Service Pack
Win7 SP1 64bits

Construct 2 Version ID
R241 64bits
B
28
S
11
G
19
Posts: 700
Reputation: 13,114

Post » Mon Jan 09, 2017 6:17 pm

This is a known bug in Chrome, which they are not planning on fixing. Not a C2 issue though so there isn't much that can be done.

https://bugs.chromium.org/p/chromium/is ... ?id=353072
B
60
S
20
G
56
Posts: 1,069
Reputation: 35,925

Post » Mon Jan 09, 2017 7:31 pm

Burvey wrote:This is a known bug in Chrome, which they are not planning on fixing. Not a C2 issue though so there isn't much that can be done.

https://bugs.chromium.org/p/chromium/is ... ?id=353072


I see, it's 2014, hell, when they fix it?, this issue it's a pain in the ass for the quality of a video game.

Thanks for the info.
B
28
S
11
G
19
Posts: 700
Reputation: 13,114

Post » Tue Jan 10, 2017 1:34 am

" Comment 5 by dalecur...@chromium.org, Mar 16 2016

We don't have any plans currently to try and make <video> or <audio> loop seamlessly."
B
60
S
20
G
56
Posts: 1,069
Reputation: 35,925

Post » Tue Jan 10, 2017 3:02 am

If you put the music in the sounds folder instead of the music folder, you can loop seamlessly.. At least I'm pretty sure I did that before... I'm always using looped music, so...
B
86
S
43
G
71
Posts: 601
Reputation: 43,609

Post » Wed Jan 11, 2017 8:29 pm

spacedoubt wrote:If you put the music in the sounds folder instead of the music folder, you can loop seamlessly.. At least I'm pretty sure I did that before... I'm always using looped music, so...


Are you sure this will not cause any problems?
B
28
S
11
G
19
Posts: 700
Reputation: 13,114

Post » Wed Jan 11, 2017 8:50 pm

The Mnk wrote:
Are you sure this will not cause any problems?



I can't think of why it would. Can you?
Every game here does it that way: http://www.jadecupmaidhands.com/
I've never ran into any issues.
Last edited by spacedoubt on Thu Jan 12, 2017 12:11 am, edited 1 time in total.
B
86
S
43
G
71
Posts: 601
Reputation: 43,609

Post » Wed Jan 11, 2017 9:56 pm

All my sounds and music is in the sounds folder and it have never been a problem for me and it loops perfectly. Only time I use the music folder is for long songs set not to loop.
B
47
S
19
G
11
Posts: 669
Reputation: 10,675

Post » Thu Jan 19, 2017 6:07 pm

Closing as it's a Chrome issue as pointed out previously. Star the issue and post in it to try and bring attention back to it.

Moving the audio to the sounds folder uses the Web Audio API instead which can loop seamlessly. The only disadvantage is it stores the whole track decompressed in memory, which isn't great for long tracks, but for short ones it's fine.
Scirra Founder
B
382
S
222
G
84
Posts: 23,981
Reputation: 189,219

Post » Wed Feb 01, 2017 2:21 pm

This is not a Chrome issue only since the same happens in FF and Edge. But putting the music files in the sound folder does correct the not looping issue.
B
7
S
1
Posts: 73
Reputation: 575


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests