Slowdown in C2

Discussion and feedback on Construct 2

Post » Thu Dec 25, 2014 2:15 am

I'm using windows 8.1 on my new laptop and I'm running into a problem where Construct 2 becomes slow to respond to my inputs. Clicking and typing take forever to respond. This is happening within the editor itself, not a running game.

My laptop easily exceeds the minimum and recommended requirements, except that I appear to have an Intel video device, which the manual says it recommends not using. Could this be causing the slowdown?
B
8
S
2
Posts: 35
Reputation: 572

Post » Thu Dec 25, 2014 3:55 am

What version of C2? A memory leak was recently fixed in r191 - I had similar problems with lots of text objects in lots of layouts. All now fixed....
A big fan of JavaScript.
B
76
S
20
G
76
Posts: 2,283
Reputation: 47,550

Post » Thu Dec 25, 2014 4:04 am

R190. I don't have any text objects at all and I'm running 1 layout with less than a dozen objects.
B
8
S
2
Posts: 35
Reputation: 572

Post » Sat Dec 27, 2014 5:53 am

Do you have any webgl effects in your project? I've found that if I apply too many demanding effects, it can slow parts of the editor to a crawl, providing 'preview effects' is enabled.
Don't lose your work. Backup your game with Dropbox.
B
44
S
10
G
10
Posts: 1,106
Reputation: 9,202

Post » Mon Dec 29, 2014 12:01 am

same problem for me, no webgl effects at all, it happens when i work during some hours, version 192.
it happens with any project, after some hours, BAM, C2 become sloooow, almost impossibel to click and work..
B
41
S
16
G
7
Posts: 1,747
Reputation: 9,957

Post » Thu Jan 08, 2015 5:19 am

TiAm wrote:Do you have any webgl effects in your project? I've found that if I apply too many demanding effects, it can slow parts of the editor to a crawl, providing 'preview effects' is enabled.


Nope. No WebGL effects present.
B
8
S
2
Posts: 35
Reputation: 572

Post » Thu Jan 08, 2015 5:27 am

it could be the intel card as you stated. Can you post what type it is? Also have you tried updating you Gfx card drivers and any other updates for your system?
B
42
S
17
G
2
Posts: 850
Reputation: 6,209

Post » Thu Jan 08, 2015 8:16 am

Same here after working for a long time with C2, the editor becomes unresponsive and slow.

I found a workaround though - when I start to feel the UI is getting sluggish, I change the skin/theme, that seems to force a refresh of the widgets and you're good to go for another few hours !
Image
Game Producer & Independent Developer - http://raphaelgervaise.com
B
24
S
9
Posts: 240
Reputation: 2,238

Post » Sat Jan 24, 2015 2:09 am

volkiller730 wrote:it could be the intel card as you stated. Can you post what type it is? Also have you tried updating you Gfx card drivers and any other updates for your system?


Yes, I've tried all of that. I'd love to post what display adapter I have, but I can't seem to find any specific info. Both the control panel and DXDiagnostic just say it's an Intel(R) HD Graphics Family.
B
8
S
2
Posts: 35
Reputation: 572

Post » Sat Jan 24, 2015 2:11 am

Refeuh wrote:Same here after working for a long time with C2, the editor becomes unresponsive and slow.

I found a workaround though - when I start to feel the UI is getting sluggish, I change the skin/theme, that seems to force a refresh of the widgets and you're good to go for another few hours !


I'll have to try that. Currently I either wait, or press Ctrl Alt Del and bring up the task manager. I don't actually do anything in the task manager, but bringing it up apparently clears my issue for a few minutes.
B
8
S
2
Posts: 35
Reputation: 572

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 4 guests