Smooth filling in sprite editor

For questions about using Classic.

Post » Sat Jun 20, 2009 9:42 am

I'm making some sprites in the sprite editor for my project, but I've run into an annoying problem. I've drawn with smooth mode on, and when I fill in the middle there are transparent lines around the edge. This is of course because of the anti-aliasing. My question is, is there any way to flood fill a sprite with colour that won't create this effect? Failing that, I'd be happy to draw the object with smooth mode off, fill it, and then anti-alias the whole sprite, but I can't find an option for this.

Here's a picture to better explain my problem:
B
3
S
1
G
3
Posts: 105
Reputation: 1,312

Post » Sat Jun 20, 2009 3:33 pm

I don't know how to fix that, but you will probably find graphics easier and more comfortable to draw in some external application. There are some good free photoshop alternatives.

Fake EDIT: increasing hardiness and thickness seems to take care of that problem. I used 2000 in both, but some smaller value should work...
B
24
S
7
G
3
Posts: 138
Reputation: 2,795

Post » Sat Jun 20, 2009 5:37 pm

The sprite editor is fine for "placeholders" while you sort your code out, but you really shouldn't be looking to do any finished artwork with it.

If you don't have access to Photoshop or PaintShopPro, then go for Free alternatives like GIMP and the photoshop lookalike Artweaver.
They'll both allow you to solve your particular problem by either painting or filling on a layer behind your outline, or by adjusting the tolerance of the fill.

Then use the Sprite Editor solely as a way of getting your artwork into your game.

Sponge.
B
2
S
1
G
3
Posts: 105
Reputation: 1,310


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 6 guests