[Solved] Animate multiples Sprite Pathfinding

Get help using Construct 2

Post » Sun Apr 21, 2013 5:41 pm

Hello !

I got an problem when trying to setup the animation for multiple instance of the sprite.

Somebody could help me to find the problem?

Thanks in advance

The CapxShiva2013-04-21 18:36:33
B
5
G
1
Posts: 11
Reputation: 947

Post » Sun Apr 21, 2013 5:44 pm

I can't open your capx because I don't have the TMX importer.

Screenshots of your events that handle the animations?
B
58
S
20
G
7
Posts: 305
Reputation: 8,804

Post » Sun Apr 21, 2013 6:02 pm

@TL22 Ok. Thanks to have a look. I have added the screenshot.

Note: I got no problem when I have only one zombie, but if I add another zombie the second have the same animation that the first one.

Maybe I should loop every zombie and then, set the animation?

https://dl.dropboxusercontent.com/u/2692790/animation.pngShiva2013-04-21 18:04:56
B
5
G
1
Posts: 11
Reputation: 947

Post » Sun Apr 21, 2013 6:35 pm

Just found the solution... I have added For each Zombie at the Is pathfinding moving along path.

Thanks anyway !
B
5
G
1
Posts: 11
Reputation: 947

Post » Mon Apr 22, 2013 2:51 am

Yeah, as soon as I saw the screenshot that was going to be my suggestion. Glad you figured it out!
B
58
S
20
G
7
Posts: 305
Reputation: 8,804

Post » Sun May 12, 2013 8:46 pm

Can you share the capx? i cant figure out that "for each" :P
B
34
S
8
G
7
Posts: 498
Reputation: 7,753

Post » Tue Mar 11, 2014 6:41 pm

It's a late reply, sorry.

Like this : https://dl.dropboxusercontent.com/u/269 ... ation2.png
B
5
G
1
Posts: 11
Reputation: 947


Return to How do I....?

Who is online

Users browsing this forum: Vodakman and 16 guests