[Solved!!] Janking It ...it was my f.lux app

Discussion and feedback on Construct 2

Post » Wed Jul 06, 2016 6:14 pm

The debug mode will eat performance. It's not exactly representative of the final performance.

I tested it without debug, runs perfectly jank free (latest chromium, nvidia graphics).
Have you tested it with the debug mode? And if so: What are your PC-specs?
B
77
S
28
G
32
Posts: 481
Reputation: 19,763

Post » Wed Jul 06, 2016 6:27 pm

Eisenhans wrote:The debug mode will eat performance. It's not exactly representative of the final performance.

I tested it without debug, runs perfectly jank free (latest chromium, nvidia graphics).
Have you tested it with the debug mode? And if so: What are your PC-specs?


I get jank in regular play mode and debug mode. My com has 12gb of RAM, an i7 processor, and Nvidia GPU. No browsers running in the background.. in fact, just regular start-up stuff running while using c2. I have the latest nvidia graphics driver, plus the newest nw.js, but that doesn't seem to matter since it happens in Firefox and Chrome too. There has to be a reason. No one sees the character kinda stutter every couple seconds while going across the platform? I feel like I'm taking crazy pills :?
B
25
S
12
G
11
Posts: 260
Reputation: 7,923

Post » Wed Jul 06, 2016 7:06 pm

I can only send you to a direction, not solve your problem.
Look at this video ...
https://www.youtube.com/watch?v=M-9sgohBIHs

Click on the program settings tab, find chrome, and make it use optimal settings.
Try chrome with and without hardware accelleration. (chrome settings)
Check the energy saving modus of you computer, set it to performance.
B
33
S
18
G
28
Posts: 2,493
Reputation: 20,950

Post » Wed Jul 06, 2016 7:43 pm

99Instances2Go wrote:I can only send you to a direction, not solve your problem.
Look at this video ...
https://www.youtube.com/watch?v=M-9sgohBIHs

Click on the program settings tab, find chrome, and make it use optimal settings.
Try chrome with and without hardware accelleration. (chrome settings)
Check the energy saving modus of you computer, set it to performance.


I wish I could say that all helped but it's the same stutter every couple seconds no matter which preview display I use and no matter if it's fullscreen or windowed. Maybe I should reset my computer. I just don't remember this stuff happening before.. but maybe it did and I didn't think about it.
B
25
S
12
G
11
Posts: 260
Reputation: 7,923

Post » Wed Jul 06, 2016 8:48 pm

I fixed it! It was the f.lux app running in the background causing the stutter. I never noticed the stutter before because I didn't install f.lux until recently. That's why this jank appeared out of nowhere! Thanks for all the help guys.
B
25
S
12
G
11
Posts: 260
Reputation: 7,923

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 24 guests