[SOLVED] Multiplayer error "specified client ID"

Discussion and feedback on Construct 2

Post » Sat Jun 06, 2015 4:22 pm

EDIT: Apparently, the engine requires a cycle or two to establish that the player has "joined a room". The "Is not in room" error, which I had built to kick players from the server, was triggering as soon as the peer joined the room. The host thought there was a peer, but the peer had kicked itself back to the menu.

Waiting at least a cycle / second before checking if a player "is not in room" solved the problem. (Perhaps I missed this requirement in the manual.)

-----

Has anyone had this error before?

I have a host creating a specifically-named room, and a peer attempting to join it. The peer requests the room list, searches it for the specifc room name, and if it's available, joins the room.

Immediately the host receives a "signalling error" from the multiplayer object, and the errormessage reads "specified client ID not in same room". The peer does not join the room.

I'm using the same methods as I am using to join public games, which work fine. Hosts can start specifcally-named rooms fine as well. It's just when the peers try to join.

Any clues would be appreciated! Thanks for reading
B
21
S
5
G
3
Posts: 66
Reputation: 2,848

Return to Construct 2 General

Who is online

Users browsing this forum: David181 and 11 guests