[SOLVED] Please check my IAP Setting (what is wrong here)

Get help using Construct 2

Post » Thu Sep 29, 2016 12:04 pm

Please see my in-app purchase setting
what I am doing wrong. I am receiving this message when I press purchase button to remove advt
"Error Authentication is required.You need to sign into your google account".

I have done
if purchase = 0
Advts will be shown
but when its become 1 then advt will go hide
when purchase will be success
purchase will be = 1
and I have save purchase value to the local storage
Image
Image
Last edited by luckyrawatlucky on Sat Oct 01, 2016 10:05 am, edited 2 times in total.
Image
B
64
S
39
G
46
Posts: 656
Reputation: 32,728

Post » Fri Sep 30, 2016 6:51 am

help
Image
B
64
S
39
G
46
Posts: 656
Reputation: 32,728

Post » Fri Sep 30, 2016 9:21 am

IAP do not work in local preview on computer/over WIFI.
As stated, you need to be on the target device, in an exported application, being connected to your Google account.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
291
S
114
G
95
Posts: 7,290
Reputation: 70,138

Post » Fri Sep 30, 2016 9:32 am

i export it and testing in device and connected with google account
even i have downloaded your tutorials example
and test my app
message saying : The item you requested is not available for purchase
Image
B
64
S
39
G
46
Posts: 656
Reputation: 32,728


Return to How do I....?

Who is online

Users browsing this forum: Artcadev, MadSpy, MaxxMunnn, Uk4dee and 28 guests