*[SOLVED]* Sound not playing on Nexus 7

Discussion and feedback on Construct 2

Post » Thu Jun 20, 2013 1:02 am

I've created two buttons on screen and want a sound to play when I press them. Here is the event sheet.



This runs fine in the firefox browser on the PC but when exporting it through Cocoonjs and running it on the Android Nexus 7 tablet everything runs fine except there is no sound when I press a button.

This is my first time experimenting putting home made stuff on a tablet and no doubt made a stupid error. Can anyone help?

Thanks. :)Nickydude2013-06-20 15:27:27
B
72
S
25
G
10
Posts: 383
Reputation: 11,171

Post » Thu Jun 20, 2013 1:14 am

Probably use the preload sound action in the start of layout and make sure your player is only able to click the button once the sound loading is complete.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
296
S
119
G
96
Posts: 7,332
Reputation: 71,306

Post » Thu Jun 20, 2013 1:27 pm

You only have a .ogg file in your screenshot. You need both .m4a and .ogg file to cover all platforms. See Importing audio
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143

Post » Thu Jun 20, 2013 3:19 pm

I did import the sound as you described Ashley and it said it converted successfully although it does say "won't convert to ACC" in the details after importing. I guess it has something to do with the sound file?

Edit:Oh and they were .ogg files to begin with.Nickydude2013-06-20 15:21:05
B
72
S
25
G
10
Posts: 383
Reputation: 11,171

Post » Thu Jun 20, 2013 3:26 pm

It was the sound file, I assumed everything was ok as it 'imported successfully'. I converted the sound to a pcm wav and reimported it and now it works fine.

Thanks for the help though, much appreciated. :)Nickydude2013-06-20 15:32:57
B
72
S
25
G
10
Posts: 383
Reputation: 11,171


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 14 guests